Skip to content

Commit

Permalink
media-libs/plotutils: EAPI-7 bump, fix pkg_postinst message
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Nov 6, 2020
1 parent 993bb72 commit 68a6ab2
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 33 deletions.
4 changes: 2 additions & 2 deletions media-libs/plotutils/files/plotutils-2.6-libpng-1.5.patch
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
fix building with libpng-1.5

--- libplot/z_write.c
+++ libplot/z_write.c
--- a/libplot/z_write.c
+++ b/libplot/z_write.c
@@ -164,7 +164,7 @@
}

Expand Down
65 changes: 34 additions & 31 deletions media-libs/plotutils/plotutils-2.6-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=7

inherit libtool eutils autotools
inherit libtool autotools

DESCRIPTION="Powerful C/C++ function library for exporting 2-D vector graphics"
HOMEPAGE="https://www.gnu.org/software/plotutils/"
Expand All @@ -12,55 +12,58 @@ SRC_URI="mirror://gnu/plotutils/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="+png static-libs X"
IUSE="+png X"

DEPEND="
!<media-libs/plotutils-${PV}
media-libs/libxmi
png? (
media-libs/libpng:0=
sys-libs/zlib )
X? ( x11-libs/libXaw )"
RDEPEND="${DEPEND}"
sys-libs/zlib
)
X? ( x11-libs/libXaw )
"
RDEPEND="${DEPEND}
!<media-libs/plotutils-${PV}
"

DOCS="AUTHORS COMPAT ChangeLog INSTALL.* KNOWN_BUGS NEWS ONEWS PROBLEMS README THANKS TODO"
DOCS=( AUTHORS COMPAT ChangeLog INSTALL.{fonts,pkg} KNOWN_BUGS NEWS ONEWS PROBLEMS README THANKS TODO )

PATCHES=(
"${FILESDIR}"/${PN}-2.5.1-rangecheck.patch
"${FILESDIR}"/${P}-makefile.patch
"${FILESDIR}"/${P}-libpng-1.5.patch
"${FILESDIR}"/${P}-libxmi.patch
"${FILESDIR}"/${P}-format-security.patch
)

src_prepare() {
rm -rf libxmi/* || die
sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
epatch \
"${FILESDIR}"/${PN}-2.5.1-rangecheck.patch \
"${FILESDIR}"/${P}-makefile.patch \
"${FILESDIR}"/${P}-libpng-1.5.patch \
"${FILESDIR}"/${P}-libxmi.patch \
"${FILESDIR}"/${P}-format-security.patch
default

rm -r libxmi/* || die
sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' -i configure.ac || die

eautoreconf
elibtoolize
}

src_configure() {
local myconf
if use X ; then
myconf="--with-x --enable-libxmi"
else
myconf="--without-x"
fi

econf \
--enable-shared \
--enable-libplotter \
--disable-libxmi \
$(use_enable static-libs static) \
$(use_with png libpng) \
${myconf}
local myeconfargs=(
--enable-shared
--enable-libplotter
--disable-libxmi
--disable-static
$(use_with png libpng)
$(usex X "--with-x --enable-libxmi" "--without-x")
)
econf "${myeconfargs[@]}"
}

pkg_postinst() {
if use X ; then
elog "There are extra fonts available in the plotutils package."
elog "The current ebuild does not install them for you since most"
elog "of them can be installed via the media-fonts/urw-fonts"
elog "package. See /usr/share/doc/${P}/INSTALL.fonts for"
elog "package. See /usr/share/doc/${PF}/INSTALL.fonts for"
elog "information on installing the remaining Tektronix fonts."
elog ""
elog "If you manually install the extra fonts and use the"
Expand Down

0 comments on commit 68a6ab2

Please sign in to comment.