Skip to content

Commit

Permalink
app-admin/awscli: Bump to 1.20.36
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Sep 4, 2021
1 parent 463bb7c commit 68b1ff7
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/awscli/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,5 @@ DIST awscli-1.20.15.tar.gz 2048948 BLAKE2B e7d378c9cb1752f4b7e014578d07fdc5f7bd9
DIST awscli-1.20.21.tar.gz 2055227 BLAKE2B 6448527363ca25f039fa9e461bf5f6451e2ecb308a29b3b62c2303d756476c45f60b5356bf32894d780deb8d9e459d83e2520ce09f5ea5f3b1e9435f8180d4ce SHA512 58b9323b8bdb07bd48814cf11fc03f9c4ffda01d1d0c85d4a77425ca37848a2cb3a6222b12c31e5897b348ef265cc94d842d9fd6b4a66bb3cfc8b37b038361cf
DIST awscli-1.20.28.tar.gz 2058578 BLAKE2B 3f6993a41f46ad9d8d45cebc0d5ea95a954e15c73d236426590c389aba6de6a99b6a5000f065f932733151c14f3112bacc25c670a05d2a991a976669ce54554e SHA512 b75974450cea3744ed15cf00ca82a35aa377c55e0ef67bb5536ed136e768d5030e6707f12e2e7de8bfce48296295ff4ed4c9f9b15c642104ea34c7492291135b
DIST awscli-1.20.35.tar.gz 2069361 BLAKE2B e19666a42ae7b39297d62532d5028beb099ba195e80233f43f28697184be10c3abb859db5271980e45cade0c6d580988b63d0c2b5e3adc66aee97e76c7883144 SHA512 7fecf089e72a520004aef0d002b2ec07c524b8f927c27e4a497cedfcbcd38e0db57c3ce7e67d4e7f4a4fd78a0ec3e950ef6d7f6d2f7918e0d03a5fb3b2ff8ddf
DIST awscli-1.20.36.tar.gz 2069853 BLAKE2B b524091d27b8200954086ffa1dc444efe3a17e34b4873098d7e50183ad5517adcd1427f8501e1c0c3f882dc0b74bd36774aa06434d1b269f8770a7e05d01d82f SHA512 690881772620d125064acafc42440307890c25d49f75c0c407eeafd094af82eb8c9583140321f53ba4c1346e8c9e4b687b3c812717fc22125045e01afd53e256
DIST awscli-1.20.7.tar.gz 2045304 BLAKE2B d8f086d8d2eb36645e77fa3d9ae7c196ed3a3fddcc2a0218696f92bd69e10b453be1340b965a8d8e6697bbd3c45013d72de3ed0d31b5823515a5a0092a812858 SHA512 a41bd3ebc34a65add66ef95d5194ba07907a08f7368b0fcd6551af2070c46c4a509af47d30aeadabddce19d1a61200a58faf40a7e2f759e64915cfb2826666ab
58 changes: 58 additions & 0 deletions app-admin/awscli/awscli-1.20.36.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PYTHON_COMPAT=( python3_{8..10} )

inherit bash-completion-r1 distutils-r1

DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="https://pypi.org/project/awscli/"
#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/aws-cli-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"

# botocore is x.(y+1).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"

distutils_enable_tests --install nose

PATCHES=(
"${FILESDIR}"/awscli-1.19.47-py39.patch
)

python_test() {
distutils_install_for_testing
# integration tests require AWS credentials and Internet access
nosetests -v tests/{functional,unit} ||
die "Tests failed for ${EPYTHON}"
}

python_install_all() {
newbashcomp bin/aws_bash_completer aws

insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws

distutils-r1_python_install_all

rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

0 comments on commit 68b1ff7

Please sign in to comment.