Skip to content

Commit

Permalink
dev-util/rosdep: bump to 0.12.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
aballier committed Mar 25, 2018
1 parent 3a4a6cd commit 68b9a65
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/rosdep/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rosdep-0.12.1.tar.gz 117102 BLAKE2B 42b0f6e7b6b0c2a4219bce24ff74ec01efb61ac0799a89baa5dc7f6b698e8f69a1578f744179252e7123c87c9fb0368b43a9a293609b28f6bfbc32c87b5f4627 SHA512 031bdfb4877865cacfab63a4494807ecf157d8514e89c7ab15e38fcbd4664df1247874975d7b1af42a8a1fc24cb62a558bd6b43732946f3122ffa6448a7631da
DIST rosdep-0.12.2.tar.gz 118343 BLAKE2B 98163feef406707772a54bf6d1825900ac593113d635de92adcac0ae7ce201c2e312116104c76c13b9c1e3b1847ef4dcc0cfb4fd1edcb2795c6b323fa9cc7167 SHA512 0932a5ff9874bbdffa1160fe0a391d27eef9a2f2435d7a89fa3b5e4eab0fc08205d4417aaea1254ab7bfe679cfeb61a6f1b199f06d65154b30505e2a280c0b61
61 changes: 61 additions & 0 deletions dev-util/rosdep/rosdep-0.12.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
fi

inherit ${SCM} distutils-r1

DESCRIPTION="Command-line tool for installing ROS system dependencies"
HOMEPAGE="http://wiki.ros.org/rosdep"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
"
KEYWORDS="~amd64 ~arm"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/rospkg[${PYTHON_USEDEP}]
dev-python/rosdistro[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/flake8[${PYTHON_USEDEP}]
)
"

python_test() {
nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
}

pkg_postrm() {
if [ "${ROOT:-/}" = "/" ] ; then
einfo "Removing rosdep default sources list."
rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
fi
}

pkg_postinst() {
if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
einfo "Initializing rosdep"
rosdep init
fi
}

0 comments on commit 68b9a65

Please sign in to comment.