Skip to content

Commit

Permalink
dev-python/rply: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
alexxy committed Jun 28, 2018
1 parent 50c4e50 commit 68d26db
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/rply/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST rply-0.7.4.tar.gz 27392 BLAKE2B 3604550646e083bf685a192dcf0dbc80c03cf4b97f6771ed37e228c84909c2518a58bde73ea584085351f1a2b5c865418ae671843087660d48f08e0e44e3ab2c SHA512 e3c3a828eb4b3cb20751ecb2d91efaabddbe3702d52b9adefe1748c07c843da1899e3944bcf0ab79f627ae428b8879cf99739ea7e0c6fd1acffc4ac4dee1b652
DIST rply-0.7.5.tar.gz 27462 BLAKE2B 0f438e6fd786e7436f135da50fe90208970a0950422bb0d8e26b06cc2def964c0ebd7c3e5e3e282a1d56dbb9e804ac267095dc4da16eb57899f455d66fed2d71 SHA512 ccecc451d9e2e0fdf9df7eaaeabface782d9159cc1caf1feae6e46210f6384aa1a78c15ea3c0e9dcc0bd0d2b28e3b1328c8d37e94a8968b07ef7938e5f5ce201
DIST rply-0.7.6.tar.gz 26216 BLAKE2B 5ec93739179df0d34762ea0ee004a00defa235a23af8b5cbf283e1e44c250469a704c9247463a8cdf9796c35da8aed0be025e73fe21aece3d376b1e66ffda1c3 SHA512 b0edcff1ca32c465b404a0b2f548f90d312bcb98d3f4aa4a61fb44986c8aa7ecb6f046e72112e2c1f5654173bcfcc96ab4e0625632e908ccf17b43cdb3d8d99d
36 changes: 36 additions & 0 deletions dev-python/rply/rply-0.7.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )

inherit distutils-r1

DESCRIPTION="Pure python parser generator that also works with RPython"
HOMEPAGE="https://github.com/alex/rply"
SRC_URI="https://github.com/alex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/appdirs[${PYTHON_USEDEP}]
test? (
dev-python/py[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}] )"

python_prepare() {
# https://github.com/alex/rply/issues/26; fail under py[3-4]
if python_is_python3; then
sed -e s':test_simple:_&:' -e s':test_empty_production:_&:' \
-i tests/test_parsergenerator.py
fi
distutils-r1_python_prepare
}

python_test() {
py.test || die "Tests fail with ${EPYTHON}"
}

0 comments on commit 68d26db

Please sign in to comment.