Skip to content

Commit

Permalink
net-misc/youtube-dl: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.10, Repoman-2.3.3
  • Loading branch information
Jeroen Roovers committed Sep 27, 2017
1 parent 4e0c207 commit 68fb0a6
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/youtube-dl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.09.11.tar.gz 2793332 SHA256 8b6defdd7cb9a8228eca2ef03a8c203a3ccba1ed97cb700f11b40a3af548212a SHA512 b38a06694c8a03d3ad83f46d6753128a69226e01f63bb9119005710bfd2bedf999a530bfd4c3d5a60026dff5033ea7508079b9bf3835013a487afaab403e9d38 WHIRLPOOL 48a526f043e7a440696a07339cae6ddfd4a11757fae9e48768a6118c78c8051bf5b0ee1c23ea32e6dff04484ed4b7aa6832dbd52353ef83f2a07bc35b068aff8
DIST youtube-dl-2017.09.15.tar.gz 2795468 SHA256 eef429c94978febb7b022ad7805adda3fdc78814c92c293eebfe2eb83fbe88cf SHA512 91b286485ba9b8706b8606f97259796b26496e4f6d0ebc61bc8f8e15eb170008be7abb868636f0ceb1d658d8bf4bdba09fa179e53d98fea94cba2d6c5b4ba363 WHIRLPOOL 98d79b73c67afacffb7409deee6b4ab7200df6a5efdde546b16b08d1bf2c164ebcadd9a8079cd789cb6051087c09e7553ce39fbb88ce5512c2765d95c1a240ca
DIST youtube-dl-2017.09.24.tar.gz 2810181 SHA256 7d7140ce63377e84a2072b4922809c7a2e90e3916cde2f4f1cc8860664395548 SHA512 de96406aeabb993a39941f5c67947fd1b77ec003be36b215cb3df1e5c90d63c7c570a5ca7627f5b2faae6a15ee07d45cf339cac6b511890acf49c5c38e6c5672 WHIRLPOOL e248990cce1bcbe50ae9e0ac6a95d760948809ec371b93126011d71599e721f1e9b0784690b832d3c5c04fb55c048b08c091193f821b18e1211f4c393ab2d017
98 changes: 98 additions & 0 deletions net-misc/youtube-dl/youtube-dl-2017.09.24.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
inherit bash-completion-r1 distutils-r1

DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://rg3.github.com/youtube-dl/"
SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="+offensive test"

RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
test? ( dev-python/nose[coverage(+)] )
"

S="${WORKDIR}/${PN}"

python_prepare_all() {
if ! use offensive; then
sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
youtube_dl/version.py || die
# these have single line import statements
local xxx=(
alphaporno anysex behindkink camwithher chaturbate eporner
eroprofile extremetube foxgay goshgay hellporno hentaistigma
hornbunny keezmovies lovehomeporn mofosex motherless myvidster
porn91 porncom pornflip pornhd pornotube pornovoisines pornoxo
ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
youporn
)
# these have multi-line import statements
local mxxx=(
drtuber fourtube pornhub redtube tnaflix xhamster
)
# do single line imports
sed -i \
-e $( printf '/%s/d;' ${xxx[@]} ) \
youtube_dl/extractor/extractors.py \
|| die

# do multiple line imports
sed -i \
-e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
youtube_dl/extractor/extractors.py \
|| die

sed -i \
-e $( printf '/%s/d;' ${mxxx[@]} ) \
youtube_dl/extractor/generic.py \
|| die

rm \
$( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
$( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
test/test_age_restriction.py \
|| die
fi

eapply_user

distutils-r1_python_prepare_all
}

src_compile() {
distutils-r1_src_compile
}

python_test() {
emake test
}

python_install_all() {
dodoc README.txt
doman ${PN}.1

newbashcomp ${PN}.bash-completion ${PN}

insinto /usr/share/zsh/site-functions
newins youtube-dl.zsh _youtube-dl

insinto /usr/share/fish/completions
doins youtube-dl.fish

distutils-r1_python_install_all

rm -r "${ED}"/usr/etc || die
}

0 comments on commit 68fb0a6

Please sign in to comment.