Skip to content

Commit

Permalink
x11-drivers/xf86-video-intel: Version bump to 2.99.917_p20230201
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Apr 12, 2023
1 parent eb47210 commit 6912501
Show file tree
Hide file tree
Showing 3 changed files with 96 additions and 2 deletions.
1 change: 1 addition & 0 deletions x11-drivers/xf86-video-intel/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST xf86-video-intel-2.99.917_p20201215.tar.bz2 1250622 BLAKE2B ddcbd84ee125528fe82f0a369f8e768d218eb0d9c4fc00cbe4a921d6267a846eccc001e3dd765f8cdaf7a38c461357831cd9675acfdfd3cc6ac282ec4b6f4b67 SHA512 29526fe191a95c2df5a3e168150b8c7f759dfdc9a4912e28887ec51be05304a9f552d21c990a37a90d6299e64df4bb1fba051c1d0ad25606dc52f801cd30b60d
DIST xf86-video-intel-2.99.917_p20230201.tar.bz2 1250201 BLAKE2B f41aa429079b60b06a4f78289c5d94de9203c55756bcc3f1ff016a9226e7fa01b3559305ea3328acbc88063c8a5a96289a0ba9954e011c4eaeb7ac5d8fc3e240 SHA512 5f37bfead71ca5a671640919c357912d15b809fe8f55f572119927b218e58bbd75f3ec4370a80d74d454debb09c678105b3120f8d7eced3f9ed858878ba9128c
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

XORG_DRI=dri
XORG_EAUTORECONF=yes
inherit linux-info xorg-3 flag-o-matic

if [[ ${PV} == 9999* ]]; then
SRC_URI=""
else
KEYWORDS="~amd64 ~x86"
COMMIT_ID="b74b67f0f321875492968f7097b9d6e82a66d7df"
SRC_URI="https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel/-/archive/${COMMIT_ID}/${P}.tar.bz2"
S="${WORKDIR}/${PN}-${COMMIT_ID}"
fi

DESCRIPTION="X.Org driver for Intel cards"

IUSE="debug +sna tools +udev uxa xvmc"

REQUIRED_USE="
|| ( sna uxa )
"
RDEPEND="
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXScrnSaver
>=x11-libs/pixman-0.27.1
>=x11-libs/libdrm-2.4.52[video_cards_intel]
>=x11-base/xorg-server-1.18
tools? (
x11-libs/libX11
x11-libs/libxcb
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libxshmfence
x11-libs/libXtst
)
udev? (
virtual/libudev:=
)
xvmc? (
>=x11-libs/libXvMC-1.0.12-r1
>=x11-libs/libxcb-1.5
x11-libs/xcb-util
)
"
DEPEND="${RDEPEND}
x11-base/xorg-proto"

pkg_setup() {
linux-info_pkg_setup
xorg-3_pkg_setup
}

src_configure() {
# bug #582910
replace-flags -Os -O2

local XORG_CONFIGURE_OPTIONS=(
--disable-dri1
$(use_enable debug)
$(use_enable dri)
$(use_enable dri dri3)
$(usex dri "--with-default-dri=3")
$(use_enable sna)
$(use_enable tools)
$(use_enable udev)
$(use_enable uxa)
$(use_enable xvmc)
)
xorg-3_src_configure
}

pkg_postinst() {
if linux_config_exists && \
kernel_is -lt 4 3 && ! linux_chkconfig_present DRM_I915_KMS; then
echo
ewarn "This driver requires KMS support in your kernel"
ewarn " Device Drivers --->"
ewarn " Graphics support --->"
ewarn " Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->"
ewarn " <*> Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver) --->"
ewarn " i915 driver"
ewarn " [*] Enable modesetting on intel by default"
echo
fi
}
4 changes: 2 additions & 2 deletions x11-drivers/xf86-video-intel/xf86-video-intel-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
EAPI=8

XORG_DRI=dri
XORG_EAUTORECONF=yes
Expand Down

0 comments on commit 6912501

Please sign in to comment.