Skip to content

Commit

Permalink
dev-java/jaxen: bump to 1.2.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.17, Repoman-3.0.2
Signed-off-by: Volkmar W. Pogatzki <[email protected]>
Closes: gentoo@06cd947
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
vaukai authored and fordfrog committed Apr 14, 2021
1 parent 6c50035 commit 6927974
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/jaxen/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST jaxen-1.1.4-src.tar.gz 268493 BLAKE2B ff51cf3b6507f19549ab864fa4cd53d0b2d0c34a21a944d22feed74d58fb71c0273f5b560cc9c02aa50748f672115e77fab24a2d986508841d6a0ba4b8911690 SHA512 11c1c744af030c50579f872d8c8bf437e48ab4a01e6dd34529f2d9039c154533edaa9b5a367a866e2b57f311f1111717be300db8f80423c5492be38e0cffc031
DIST jaxen-1.1.6.jar 409677 BLAKE2B 55e03939420c103fb5a6d323595ff0cb7653885eb9ba233fd581c5376d2ac90eecde7aa5576f602cdc459cfd9ba9e79c6bb5bfab3ed7805e717a21670a5748ee SHA512 979044fe959493eb6d66fa92b420251cd9c12414051ff6956d5835888a8999d4f337c18646c53806fc19203cef744f53b7597850cd2f695910c90df7a9725b48
DIST jaxen-1.2.0.tar.gz 282829 BLAKE2B 4d89d4fd3dfd8c4113fe7ecc05597ea9dd743d9c871f320936809016ae8cb3a3d4fb3f935de19463e6c99db1b67eff3545e909b707e81f4c0f114ec0f0e7bb97 SHA512 cecfc62eab1cf6586b28594855bd983679a932dbdc6cbdd07d85a9a9458e78b2e784dfd6287e6e87e4f4443239eefbeac59a7316dae53b818379daaccae56b53
63 changes: 63 additions & 0 deletions dev-java/jaxen/jaxen-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Skeleton command:
# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/jaxen-xpath/jaxen/archive/refs/tags/v1.2.0.tar.gz --slot 1.2 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jaxen-1.2.0.ebuild

EAPI=7

JAVA_PKG_IUSE="doc source test"
MAVEN_ID="jaxen:jaxen:1.2.0"
JAVA_TESTING_FRAMEWORKS="junit"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Jaxen is a universal XPath engine for Java."
HOMEPAGE="http://www.cafeconleche.org/jaxen/"
SRC_URI="https://github.com/${PN}-xpath/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="1.2"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"

# It seems that most tests depend on dom4j, jdom and xom which all depend on jaxen
RESTRICT="test"

# Compile dependencies
# POM: pom.xml
# xerces:xercesImpl:2.6.2 -> >=dev-java/xerces-2.12.0:2
# xml-apis:xml-apis:1.3.02 -> >=dev-java/xml-commons-external-1.4.01:1.4
# POM: pom.xml
# test? junit:junit:3.8.2 -> >=dev-java/junit-3.8.2:0

DEPEND="
>=virtual/jdk-1.8:*
${CDEPEND}
>=dev-java/xerces-2.12.0:2
"

RDEPEND="
>=virtual/jre-1.8:*
${CDEPEND}
"

S="${WORKDIR}"

DOCS=( "${P}"/{LICENSE.txt,README.md} )

JAVA_CLASSPATH_EXTRA="xerces-2"
JAVA_SRC_DIR="${P}/src/java/main"

src_prepare() {
default

# solve cyclic deps by removing these dirs
# dom4j, jdom and xom depend on jaxen
# https://bugs.gentoo.org/739894#c9
rm -rv "${JAVA_SRC_DIR}"/org/jaxen/{dom4j,jdom,xom} || die
}

src_install() {
default
java-pkg-simple_src_install
}

0 comments on commit 6927974

Please sign in to comment.