forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Gentoo-bug: 594594 Package-Manager: portage-2.3.1
- Loading branch information
Michael Palimaka
committed
Sep 22, 2016
1 parent
8cd0a1a
commit 692d0c2
Showing
4 changed files
with
127 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST krita-3.0.1.tar.gz 206137161 SHA256 3c820ec30c3f4c93a33e2982571017eac8f8af2a734a6a1474ef11e1db26d006 SHA512 4d3446b90f7d5e9049ce77e9ac0dff2868dfe8ee1c707eec5d4c9d8e2168867447499079bae63ba45cc4f887ff00f0c91221e9a95c2185c0b023a1be02f09305 WHIRLPOOL 4e7165fa508616f2c36bd22b5a1a4d5c8147a0340ad6dcf1b183a85306aa9d052eea4bf7e068d1e358a1272baaa16ca316fac8fbc1515c1c1bcfae72138c8951 | ||
DIST krita-3.0.tgz 193020370 SHA256 4cea85623b709d6d32084c98a0fd76b97ad96d11be9808fca9fcaad2839a9c5a SHA512 a32507b010b5b785a40d830beb49272155d502c4c27ba874f1c9e75cbf49c7f1f730b3ecef06f24fc1ee9d3e9505c940bc20cb275f97c65e090cc5a59529486b WHIRLPOOL fe3b7b308aa754b597375aad49ef5f07d4e0e346f0109aec3b731d6dc1aea320380b01a2166a305c8cc578cad44cc19a1b4ba7fdabf9f7a841e3d5e0bae3e7fa |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
Avoid installing files that collide with kde-plasma/breeze. | ||
|
||
Gentoo-bug: 594594 | ||
KDE-bug: 368093 | ||
|
||
--- a/krita/data/themes/CMakeLists.txt | ||
+++ b/krita/data/themes/CMakeLists.txt | ||
@@ -1,8 +1,6 @@ | ||
########### install files ############### | ||
|
||
install(FILES | ||
-BreezeDark.colors | ||
-BreezeHighContrast.colors | ||
BreezeLight.colors | ||
KritaNeutral.colors | ||
KritaBlender.colors |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
Avoid automagic CXXFLAG detection courtesy of dev-libs/vc. | ||
|
||
Gentoo-bug: 584118 | ||
|
||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -525,10 +525,6 @@ | ||
endif() | ||
endmacro() | ||
|
||
- if (NOT PACKAGERS_BUILD) | ||
- # Optimize everything for the current architecture | ||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Vc_DEFINITIONS}") | ||
- endif () | ||
endif() | ||
set(CMAKE_MODULE_PATH ${OLD_CMAKE_MODULE_PATH} ) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,93 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
KDE_TEST="forceoptional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Free digital painting application. Digital Painting, Creative Freedom!" | ||
HOMEPAGE="https://www.kde.org/applications/graphics/krita/ https://krita.org/" | ||
SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="color-management fftw +gsl +jpeg openexr pdf +raw tiff vc" | ||
|
||
COMMON_DEPEND=" | ||
$(add_frameworks_dep karchive) | ||
$(add_frameworks_dep kcompletion) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kguiaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kitemmodels) | ||
$(add_frameworks_dep kitemviews) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kwindowsystem) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_qt_dep qtconcurrent) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtgui '-gles2') | ||
$(add_qt_dep qtnetwork) | ||
$(add_qt_dep qtprintsupport) | ||
$(add_qt_dep qtsvg) | ||
$(add_qt_dep qtwidgets) | ||
$(add_qt_dep qtx11extras) | ||
$(add_qt_dep qtxml) | ||
dev-libs/boost:= | ||
media-gfx/exiv2:= | ||
media-libs/lcms | ||
media-libs/libpng:= | ||
net-misc/curl | ||
sys-libs/zlib | ||
virtual/opengl | ||
x11-libs/libX11 | ||
x11-libs/libxcb | ||
x11-libs/libXi | ||
color-management? ( media-libs/opencolorio ) | ||
fftw? ( sci-libs/fftw:3.0= ) | ||
gsl? ( sci-libs/gsl:= ) | ||
jpeg? ( virtual/jpeg:0 ) | ||
openexr? ( | ||
media-libs/ilmbase:= | ||
media-libs/openexr | ||
) | ||
pdf? ( app-text/poppler[qt5] ) | ||
raw? ( media-libs/libraw:= ) | ||
tiff? ( media-libs/tiff:0 ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
dev-cpp/eigen:3 | ||
dev-lang/perl | ||
sys-devel/gettext | ||
vc? ( >=dev-libs/vc-1.1.0 ) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
!app-office/calligra:4[calligra_features_krita] | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}-breeze-collisions.patch" | ||
"${FILESDIR}/${P}-vc-cxxflags.patch" | ||
) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DWITH_FFTW3=$(usex fftw) | ||
-DWITH_GSL=$(usex gsl) | ||
-DWITH_JPEG=$(usex jpeg) | ||
-DWITH_LibRaw=$(usex raw) | ||
-DWITH_OCIO=$(usex color-management) | ||
-DWITH_OpenEXR=$(usex openexr) | ||
-DWITH_Poppler=$(usex pdf) | ||
-DWITH_TIFF=$(usex tiff) | ||
-DWITH_Vc=$(usex vc) | ||
) | ||
|
||
kde5_src_configure | ||
} |