Skip to content

Commit

Permalink
app-misc/solaar: bump
Browse files Browse the repository at this point in the history
Signed-off-by: Robin H. Johnson <[email protected]>
  • Loading branch information
robbat2 committed Jul 27, 2020
1 parent 0dc8c82 commit 69493cb
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/solaar/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST solaar-1.0.1.tar.gz 1195660 BLAKE2B e6cd89b5735e125dd438255a8961b1d5d38feb515c5097efec0403d99b9db6e29c439c13e279fcffe69cb314bf2650a7a11770830fdf1e971ade27ce8331aed2 SHA512 e0b2bbfd97d9650d94f1a4b47e4e70f09c75f684e7e1d3e67d2cf6dd197109084e941b98333e173fb205d5c9464dd07e17390d9c2d5b46393fee2efdb20429ac
DIST solaar-1.0.2.tar.gz 1540722 BLAKE2B 66c6f7c347f5eba538d3d48ff1c1137c1c71bf84dfb1a306a94e3cb24810378864066644a82d27eaaee2d80d30bcd30bb71ebe80fdb12363e9b194df9054946d SHA512 5f97b51e7853386311c5b9ff968a72529d55837f7262786e86085e130d219ac22095c20c984e340f619a15b8242f90e66a6c678c5e0c507c261d0430b74eacd6
DIST solaar-1.0.3rc1.tar.gz 782803 BLAKE2B a4dde7238f2616d98cafafa775050fd0c3a3aaf8a11b0eab333993a9246c321c45ebe4d30adddf82d826e1909a8e90cb0914472ab40f9ed5560d380931aea591 SHA512 845c55865ef93c163bae80dfe6e8e3013363cff1be03b167dcd4f30c541ae16e1828ed6e51c8c77aa8b067e3a75cd8e1980fb8847b308d067a816598f83c8d83
59 changes: 59 additions & 0 deletions app-misc/solaar/solaar-1.0.3_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_USE_SETUPTOOLS=bdepend
PYTHON_COMPAT=( python3_{6,7,8} )

inherit linux-info udev xdg distutils-r1

DESCRIPTION="Linux Device Manager for Logitech Unifying Receivers and Paired Devices"
HOMEPAGE="https://pwr-solaar.github.io/Solaar/"
SRC_URI="https://github.com/pwr-Solaar/Solaar/archive/${PV/_rc/rc}.tar.gz -> ${P/_rc/rc}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="doc appindicator libnotify"

RDEPEND="
acct-group/plugdev
dev-python/pygobject:3[${PYTHON_USEDEP}]
>=dev-python/pyudev-0.13[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
appindicator? ( dev-libs/libappindicator:3 )
libnotify? ( x11-libs/libnotify )"
# libappindicator & libnotify are entirely optional and detected at runtime

S="${WORKDIR}"/Solaar-${PV/_rc/rc}

CONFIG_CHECK="~HID_LOGITECH_DJ ~HIDRAW"

python_prepare_all() {
# don't autostart (bug #494608)
sed -i \
-e '/yield autostart_path/d' \
setup.py || die

sed -i -r \
-e '/yield.*udev.*rules.d/{s,/etc,/lib,g}' \
setup.py || die

# grant plugdev group rw access
sed -i 's/#MODE=/MODE=/' rules.d/42-logitech-unify-permissions.rules || die

distutils-r1_python_prepare_all
}

python_install_all() {
distutils-r1_python_install_all

dodoc docs/devices.md
if use doc; then
dodoc -r docs/*
else
newdoc docs/index.md README.md
fi
udev_dorules "${S}"/rules.d/42-logitech-unify-permissions.rules
}

0 comments on commit 69493cb

Please sign in to comment.