Skip to content

Commit

Permalink
dev-games/godot: fix build with musl+gcc13
Browse files Browse the repository at this point in the history
Not extensively checked with musl, so there could still be issues.

Closes: https://bugs.gentoo.org/906363
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Jun 5, 2023
1 parent 6a39ca9 commit 694bb52
Show file tree
Hide file tree
Showing 4 changed files with 26 additions and 0 deletions.
15 changes: 15 additions & 0 deletions dev-games/godot/files/godot-3.5.2-gcc13.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
Issues seem(?) to only trigger when gcc13 is combined with musl.

https://bugs.gentoo.org/906363
--- a/modules/fbx/fbx_parser/FBXCommon.h
+++ b/modules/fbx/fbx_parser/FBXCommon.h
@@ -78,2 +78,3 @@

+#include <cstdint>
#include <string>
--- a/thirdparty/vhacd/inc/vhacdManifoldMesh.h
+++ b/thirdparty/vhacd/inc/vhacdManifoldMesh.h
@@ -17,2 +17,3 @@
#define VHACD_MANIFOLD_MESH_H
+#include <cstdint>
#include "vhacdCircularList.h"
9 changes: 9 additions & 0 deletions dev-games/godot/files/godot-4.0.3-gcc13.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
Issues seem(?) to only trigger when gcc13 is combined with musl.

https://bugs.gentoo.org/906363
--- a/thirdparty/vhacd/inc/vhacdManifoldMesh.h
+++ b/thirdparty/vhacd/inc/vhacdManifoldMesh.h
@@ -17,2 +17,3 @@
#define VHACD_MANIFOLD_MESH_H
+#include <cstdint>
#include "vhacdCircularList.h"
1 change: 1 addition & 0 deletions dev-games/godot/godot-3.5.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -69,6 +69,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-3.5-musl.patch
"${FILESDIR}"/${PN}-3.5-scons.patch
"${FILESDIR}"/${PN}-3.5.2-gcc13.patch
)

src_prepare() {
Expand Down
1 change: 1 addition & 0 deletions dev-games/godot/godot-4.0.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -72,6 +72,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.0_beta3-headless-header.patch
"${FILESDIR}"/${PN}-4.0_rc2-musl.patch
"${FILESDIR}"/${PN}-4.0_rc3-scons.patch
"${FILESDIR}"/${PN}-4.0.3-gcc13.patch
)

src_prepare() {
Expand Down

0 comments on commit 694bb52

Please sign in to comment.