Skip to content

Commit

Permalink
app-portage/golop: Make location of log file prefix-aware
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Tobias Klausmann <[email protected]>
  • Loading branch information
klausman committed Feb 25, 2019
1 parent 220900b commit 696b5fc
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 2 deletions.
36 changes: 36 additions & 0 deletions app-portage/golop/golop-0.0.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
EGO_PN=github.com/klausman/golop

if [[ ${PV} = *9999* ]]; then
inherit golang-vcs
else
KEYWORDS="~amd64 ~x86"
EGIT_COMMIT=v${PV}
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
inherit golang-vcs-snapshot
fi
inherit golang-build prefix

DESCRIPTION="A pure Go re-implementation of genlop"
HOMEPAGE="https://github.com/klausman/golop"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
DEPEND=""
RDEPEND=""

src_prepare() {
sed -i -e 's@/var/log/emerge.log@'"${EPREFIX}"'&@g' src/github.com/klausman/golop/main.go || die
default
}

src_install() {
dobin ${PN}

declare -a DOCS
DOCS+=( src/${EGO_PN}/README.md )
einstalldocs
}
9 changes: 7 additions & 2 deletions app-portage/golop/golop-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
Expand All @@ -12,7 +12,7 @@ else
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
inherit golang-vcs-snapshot
fi
inherit golang-build
inherit golang-build prefix

DESCRIPTION="A pure Go re-implementation of genlop"
HOMEPAGE="https://github.com/klausman/golop"
Expand All @@ -22,6 +22,11 @@ IUSE=""
DEPEND=""
RDEPEND=""

src_prepare() {
sed -i -e 's@/var/log/emerge.log@'"${EPREFIX}"'&@g' src/github.com/klausman/golop/main.go || die
default
}

src_install() {
dobin ${PN}

Expand Down

0 comments on commit 696b5fc

Please sign in to comment.