forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/xapian-bindings: version bump to 1.2.22
Package-Manager: portage-2.2.24
- Loading branch information
Showing
2 changed files
with
204 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST xapian-bindings-1.2.19.tar.xz 828904 SHA256 3b9434c6144cc347783175c92829f304e86919bbbd44f51b7b4a7148960cde17 SHA512 ac72ec35ae3b767e04e848a9782b41d74e99b6b1f795d5096373911ff549b3bf2e602a91ed0e5f7dce2e43e1dd308af710719e5a80c6a179393aac4af316de30 WHIRLPOOL 33770203390fea6f6048ebdc63cb7031f53a30be3568e3f3f6f8a25f8aa30a284347b402e360c0c2182069e3f6dab067fc5f6cd2b950f45e196afe057e4d80e3 | ||
DIST xapian-bindings-1.2.21.tar.xz 842696 SHA256 28a39247ac875be2dc1386c273167aab5c9949227c1070b65ca8de603c06d546 SHA512 bebb4c6fce57f9b54b307bf921e760efe8fbd06d404629cfb80717eed9bfb886c82559c2ba2b333a4e24ce14d389c916ca36924f9d4b2f72fae183d4a00e635b WHIRLPOOL 065efe7c9ad38f8f27a2fb109969b1ec6eb2ef403cb6e194f7c5f4147cb666931f2e70f698f6c974916087489af7ea05e0c8c1a2a39232d1176083b624ff5cf6 | ||
DIST xapian-bindings-1.2.22.tar.xz 844040 SHA256 b15ca7984980a1d2aedd3378648ef5f3889cb39a047bac1522a8e5d04f0a8557 SHA512 0eec204ebb92f1230b9dbd080ad2b56ea5fa8e6170eb4354556e5790c7a7da7ba4c8475aaf86fb8f10f102a461d91590184271220626315f55c0631e73e122e0 WHIRLPOOL 05ac5b31d73f9de0c101da832ef289f6a505baa68216eba6fa0cf80df1709feef7e42c7b8f4cf9af35f775e8514c6d4b944c2acebffff10bc558a83305a637ce | ||
DIST xapian-bindings-1.3.3.tar.xz 1195784 SHA256 a443a16ac8279daa5b50d3308861034f859f71c824ff5fa2d75cfda3cf31858f SHA512 db0f672cdc886b975dcfdec9ec1b30401627fdecdafe5381f0da41da1bebe3c15d80d6126fa443107ba1b7c259f15ff26c08f7b18524f620b2cb8e48f2c4c2d7 WHIRLPOOL beee4de0346bbcb11dd3c5f14b775e61a9cd2dbfc03fd61f12af90e883f09495a2a951543cd001a7e778920901c2a7001cd22d0179c5173f13cf543ce9b60c98 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,203 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
PYTHON_REQ_USE="threads" | ||
|
||
USE_PHP="php5-5" | ||
|
||
PHP_EXT_NAME="xapian" | ||
PHP_EXT_INI="yes" | ||
PHP_EXT_OPTIONAL_USE="php" | ||
|
||
#mono violates sandbox, we disable it until we figure this out | ||
#inherit java-pkg-opt-2 mono-env php-ext-source-r2 python | ||
inherit java-pkg-opt-2 php-ext-source-r2 python-r1 toolchain-funcs | ||
|
||
DESCRIPTION="SWIG and JNI bindings for Xapian" | ||
HOMEPAGE="http://www.xapian.org/" | ||
SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86" | ||
#IUSE="java lua mono perl php python ruby tcl" | ||
#REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )" | ||
IUSE="java lua perl php python ruby tcl" | ||
REQUIRED_USE="|| ( java lua perl php python ruby tcl )" | ||
|
||
COMMONDEPEND="~dev-libs/xapian-${PV} | ||
lua? ( dev-lang/lua:0 ) | ||
perl? ( dev-lang/perl:= ) | ||
ruby? ( dev-lang/ruby:= ) | ||
tcl? ( >=dev-lang/tcl-8.1:0= )" | ||
# mono? ( >=dev-lang/mono-1.0.8 ) | ||
DEPEND="${COMMONDEPEND} | ||
virtual/pkgconfig | ||
java? ( >=virtual/jdk-1.3 )" | ||
RDEPEND="${COMMONDEPEND} | ||
java? ( >=virtual/jre-1.3 )" | ||
|
||
pkg_setup() { | ||
java-pkg-opt-2_pkg_setup | ||
} | ||
|
||
src_unpack() { | ||
default | ||
} | ||
|
||
src_prepare() { | ||
java-pkg-opt-2_src_prepare | ||
if use java; then | ||
sed \ | ||
-e 's/$(JAVAC)/$(JAVAC) $(JAVACFLAGS)/' \ | ||
-i java{/,/org/xapian/errors/,/org/xapian/}Makefile.in || die "sed failed" | ||
fi | ||
|
||
if use python; then | ||
sed \ | ||
-e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \ | ||
-e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian.so|' \ | ||
-i python/Makefile.in || die "sed failed" | ||
fi | ||
} | ||
|
||
src_configure() { | ||
if use java; then | ||
CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)" | ||
fi | ||
|
||
if use perl; then | ||
export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')" | ||
export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')" | ||
fi | ||
|
||
if use lua; then | ||
export LUA_LIB="$($(tc-getPKG_CONFIG) --variable=INSTALL_CMOD lua)" | ||
fi | ||
|
||
econf \ | ||
$(use_with java) \ | ||
$(use_with lua) \ | ||
$(use_with perl) \ | ||
$(use_with php) \ | ||
$(use_with python) \ | ||
$(use_with ruby) \ | ||
$(use_with tcl) | ||
# $(use_with mono csharp) \ | ||
|
||
# PHP and Python bindings are built/tested/installed manually. | ||
sed -e "/SUBDIRS =/s/ php//" -i Makefile || die "sed Makefile" | ||
sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile" | ||
} | ||
|
||
src_compile() { | ||
default | ||
|
||
if use php; then | ||
local php_slot | ||
for php_slot in $(php_get_slots); do | ||
cp -r php php-${php_slot} | ||
emake -C php-${php_slot} \ | ||
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \ | ||
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \ | ||
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \ | ||
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" | ||
done | ||
fi | ||
|
||
if use python; then | ||
python_copy_sources | ||
# building() { | ||
# emake -C python \ | ||
# PYTHON="$(PYTHON)" \ | ||
# PYTHON_INC="$(python_get_includedir)" \ | ||
# PYTHON_LIB="$(python_get_libdir)" \ | ||
# PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \ | ||
# pkgpylibdir="$(python_get_sitedir)/xapian" | ||
# } | ||
building() { | ||
emake -C python \ | ||
PYTHON_INC="$(python_get_includedir)" \ | ||
pkgpylibdir="$(python_get_sitedir)/xapian" | ||
VERBOSE="1" | ||
} | ||
python_foreach_impl building | ||
fi | ||
} | ||
|
||
src_test() { | ||
default | ||
|
||
if use php; then | ||
local php_slot | ||
for php_slot in $(php_get_slots); do | ||
emake -C php-${php_slot} \ | ||
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \ | ||
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \ | ||
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \ | ||
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \ | ||
check | ||
done | ||
fi | ||
|
||
if use python; then | ||
testing() { | ||
emake -C python \ | ||
PYTHON_INC="$(python_get_includedir)" \ | ||
pkgpylibdir="$(python_get_sitedir)/xapian" \ | ||
VERBOSE="1" \ | ||
check | ||
} | ||
python_foreach_impl testing | ||
fi | ||
} | ||
|
||
src_install () { | ||
emake DESTDIR="${D}" install | ||
|
||
if use java; then | ||
java-pkg_dojar java/built/xapian_jni.jar | ||
# TODO: make the build system not install this... | ||
java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so" | ||
rm "${D}/${S}/java/built/libxapian_jni.so" | ||
rmdir -p "${D}/${S}/java/built" | ||
rmdir -p "${D}/${S}/java/native" | ||
fi | ||
|
||
if use php; then | ||
local php_slot | ||
for php_slot in $(php_get_slots); do | ||
emake DESTDIR="${D}" -C php-${php_slot} \ | ||
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \ | ||
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \ | ||
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \ | ||
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \ | ||
install | ||
done | ||
|
||
php-ext-source-r2_createinifiles | ||
fi | ||
|
||
if use python; then | ||
installation() { | ||
emake -C python \ | ||
DESTDIR="${D}" \ | ||
PYTHON_INC="$(python_get_includedir)" \ | ||
pkgpylibdir="$(python_get_sitedir)/xapian" \ | ||
VERBOSE="1" \ | ||
install | ||
} | ||
python_foreach_impl installation | ||
fi | ||
|
||
# For some USE combinations this directory is not created | ||
if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then | ||
mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}" | ||
fi | ||
|
||
dodoc AUTHORS HACKING NEWS TODO README | ||
} |