Skip to content

Commit

Permalink
sys-libs/libsepol: bump to 2.7_rc1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
perfinion committed Jun 13, 2017
1 parent e72fcb2 commit 69a274b
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-libs/libsepol/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libsepol-2.5.tar.gz 438730 SHA256 2bdeec56d0a08b082b93b40703b4b3329cc5562152f7254d8f6ef6b56afe850a SHA512 ea781a9a61ee7036abd221422f411451e15d01202de64b167c61886644d6e9ec81916dd770bc644ba2453ff177ac91f280be63df0e20b469b4f778ce3bfdedd9 WHIRLPOOL f1a4614eae84cd07eb909c88342628d5abd3db6123907c437c680e39930137f5d07f91ce46353fbd73f42d97126f1b70dffba814d791f3931e116daf391f4531
DIST libsepol-2.6.tar.gz 442549 SHA256 d856d6506054f52abeaa3543ea2f2344595a3dc05d0d873ed7f724f7a16b1874 SHA512 17d007857634e3d581fcc9bafcbb75674a06e382bb258c2c6b3656c141d71493699c42b78c8e1917c628476aeb8ead73bb86e8ccf43d7ce59aa0b7884bea132a WHIRLPOOL c02b9dc9dcf13ce3f200293695565dec4a220f7a6b29c76121ba5a4f8c05fb347a034763f417927ed7b1952a4989a7738c9327dc47cd976410db695fd6e662ae
DIST libsepol-2.7-rc1.tar.gz 471201 SHA256 a00523b53c6f96e5a811a0315b02db0f290b19c8f8376369216aaa08377dcbc6 SHA512 040107fdd03f36c5f8a02220f930c16256e93891d2e934f2b45ee29938809d72192efb5c59a900c2802f73cfd9670ff7758083544376ee5c58a992651e8ea12d WHIRLPOOL d75e046a5f7298503b837c65147ca970e243ea23d07c96f67090758fed4a058dfcfa98d711f25f7bec3fd65238faa78a16132e23efdd3df6aabcfe49a7a29f9e
48 changes: 48 additions & 0 deletions sys-libs/libsepol/libsepol-2.7_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit multilib toolchain-funcs multilib-minimal

MY_P="${P//_/-}"
MY_RELEASEDATE="20170609"

DESCRIPTION="SELinux binary policy representation library"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${MY_P}/${PN}"
else
SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
S="${WORKDIR}/${MY_P}"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE=""

DEPEND=""
RDEPEND=""

# tests are not meant to be run outside of the full SELinux userland repo
RESTRICT="test"

src_prepare() {
eapply_user
multilib_copy_sources
}

multilib_src_compile() {
tc-export RANLIB;
LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
emake AR="$(tc-getAR)" CC="$(tc-getCC)"
}

multilib_src_install() {
LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
emake DESTDIR="${D}" install
}

0 comments on commit 69a274b

Please sign in to comment.