Skip to content

Commit

Permalink
app-backup/restic: verbump to 0.9.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: David Roman <[email protected]>
Closes: gentoo#10767
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
stkw0 authored and Whissi committed Mar 15, 2019
1 parent b3307ca commit 69a4056
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/restic/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST restic-0.8.3.tar.gz 48746281 BLAKE2B 4161326068165b5ba19e9ee0e6386aa1df29a961a42509a2cb7924958100b9412abd1dd27d299d1eef76fdd4731d4a56f0a68e796a46071229a3e6767d3a6bb7 SHA512 758b2c69af8aad6bb62dc750141d5f5a1954ca2b51350ef59c35fd10afefaddc4d8d0cdd5914f249594946db6138124a48fba531b8a24353f022ccea773a240c
DIST restic-0.9.2.tar.gz 27344284 BLAKE2B 17c121a0d4df470397b467e09ceac559848c34e6a43f289b68eff8b85af86a18a4d2e1340060812613cb7e9cecf86f706565a6bcce31fbcd5aab076a85b57c67 SHA512 e060e0e16031924df7347ec74972bf52c75c84cca8ae996b1c5dd8a6f42c9022062e004ec17af2ebc0b6e9480ecfdff4ca7f64956afab9b9799201848d0be731
DIST restic-0.9.3.tar.gz 26183792 BLAKE2B 2bb98bd0b5430f928cdc566e558e503d84e611d05da8866f4f5d6f75a325ed73e7674098d73976d8f37ba8d38232adaedc25e2ea211403ea482cecc81f476ba9 SHA512 a8d906984d17e46533a377fba464d909a92016595d7585f37942bc68c24f9356c47df83f2e6ec15b877ea20f864be87362db4421665b594fecb4bca78b520393
DIST restic-0.9.4.tar.gz 26211163 BLAKE2B 950a8da8217500a910f0e5966787b668417f1168e81365ecda70469ef42c24fed876e97b6a44ed9dda89c07760db4678d791960d78760d68c8f1846c827cf340 SHA512 8e75a1da6ee9a364c2bf53ce8f9b014549e7065eae349dc6baf68b0e8a8e9736f83c0495b822aac87480751f448bd42da34c440290b5f0967aea7becda5c448b
54 changes: 54 additions & 0 deletions app-backup/restic/restic-0.9.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit bash-completion-r1 golang-vcs-snapshot

DESCRIPTION="A backup program that is fast, efficient and secure"
HOMEPAGE="https://restic.github.io/"
SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
EGO_PN="github.com/restic/restic"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="test"

RDEPEND="sys-fs/fuse:0"
DEPEND="${RDEPEND}"

S="${WORKDIR}/${P}/src/${EGO_PN}"

src_compile() {
local mygoargs=(
-v
-work
-x
-tags release
-ldflags "-X main.version=${PV}"
-asmflags "-trimpath=${S}"
-gcflags "-trimpath=${S}"
-o restic ${EGO_PN}/cmd/restic
)

GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
go build "${mygoargs[@]}" || die
}

src_test() {
GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
go test -timeout 30m -v -work -x ${EGO_PN}/cmd/... ${EGO_PN}/internal/... || die
}

src_install() {
dobin restic

newbashcomp doc/bash-completion.sh "${PN}"

insinto /usr/share/zsh/site-functions
newins doc/zsh-completion.zsh _restic

doman doc/man/*
dodoc doc/*.rst
}

0 comments on commit 69a4056

Please sign in to comment.