Skip to content

Commit

Permalink
dev-python/speaklater: Fix Python 3 support, add Python 3.5 and tests
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
Closes: gentoo#1293

Signed-off-by: Ian Delaney <[email protected]>
  • Loading branch information
sbraz authored and Ian Delaney committed Apr 18, 2016
1 parent ccfce9c commit 69b1ea1
Show file tree
Hide file tree
Showing 2 changed files with 18 additions and 3 deletions.
1 change: 1 addition & 0 deletions dev-python/speaklater/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -8,5 +8,6 @@
<upstream>
<remote-id type="pypi">speaklater</remote-id>
<remote-id type="github">mitsuhiko/speaklater</remote-id>
<bugs-to>https://github.com/mitsuhiko/speaklater/issues</bugs-to>
</upstream>
</pkgmetadata>
20 changes: 17 additions & 3 deletions dev-python/speaklater/speaklater-1.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
EAPI=6
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
inherit distutils-r1

DESCRIPTION="Lazy strings for Python"
Expand All @@ -17,3 +17,17 @@ IUSE="test"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""

python_prepare() {
# https://github.com/mitsuhiko/speaklater/issues/2
if python_is_python3; then
2to3 -n -w --no-diffs ${PN}.py || die
2to3 -d -n -w --no-diffs ${PN}.py || die
# fix unicode in doctests
sed -ri "s/(^ {4}l?)u'/\1'/" ${PN}.py || die
fi
}

python_test() {
"${PYTHON}" -m doctest -v ${PN}.py || die "tests failed with ${EPYTHON}"
}

0 comments on commit 69b1ea1

Please sign in to comment.