Skip to content

Commit

Permalink
dev-libs/libixion: Fix bashisms in configure.ac, --disable-static
Browse files Browse the repository at this point in the history
Reported-by: Matt Whitlock <[email protected]>
Thanks-to: Lars Wendler <[email protected]>
Closes: https://bugs.gentoo.org/723128
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed May 28, 2020
1 parent d131fa2 commit 69f45f3
Show file tree
Hide file tree
Showing 3 changed files with 43 additions and 8 deletions.
32 changes: 32 additions & 0 deletions dev-libs/libixion/files/libixion-0.15.0-bashism.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From 076f6576e7398842457d34fd68140512795c7e00 Mon Sep 17 00:00:00 2001
From: Lars Wendler <[email protected]>
Date: Fri, 15 May 2020 12:42:20 +0200
Subject: [PATCH] configure.ac: avoid bashisms

or else we end up with unpredictable results if shell != /bin/bash:

./configure: 19427: test: xno: unexpected operator

Reported-by: Matt Whitlock <[email protected]>
Gentoo-bug: https://bugs.gentoo.org/723128
Signed-off-by: Lars Wendler <[email protected]>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 3a07dd8..505aeba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -182,7 +182,7 @@ AC_ARG_ENABLE([werror],
[enable_werror="$enableval"],
[enable_werror=no]
)
-AS_IF([test x"$enable_werror" == "xyes"], [
+AS_IF([test x"$enable_werror" = "xyes"], [
CXXFLAGS="$CXXFLAGS -Werror"
])

--
2.26.2

15 changes: 9 additions & 6 deletions dev-libs/libixion/libixion-0.15.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,22 +4,22 @@
EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )
inherit python-single-r1
inherit autotools python-single-r1

DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"

if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
inherit git-r3 autotools
inherit git-r3
else
SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~x86"
fi

LICENSE="MIT"
SLOT="0/0.15" # based on SONAME of libixion.so
IUSE="debug python static-libs +threads"
IUSE="debug python +threads"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

Expand All @@ -32,22 +32,25 @@ DEPEND="${RDEPEND}
dev-libs/spdlog
"

PATCHES=( "${FILESDIR}/${P}-musl-clang.patch" ) # bug 714018
PATCHES=(
"${FILESDIR}/${P}-musl-clang.patch" # bug 714018
"${FILESDIR}/${P}-bashism.patch" # bug 723128
)

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
default
[[ ${PV} == *9999 ]] && eautoreconf
eautoreconf
}

src_configure() {
local myeconfargs=(
--disable-static
$(use_enable debug)
$(use_enable python)
$(use_enable static-libs static)
$(use_enable threads)
)
econf "${myeconfargs[@]}"
Expand Down
4 changes: 2 additions & 2 deletions dev-libs/libixion/libixion-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -21,7 +21,7 @@ fi

LICENSE="MIT"
SLOT="0/0.16" # based on SONAME of libixion.so
IUSE="debug python static-libs +threads"
IUSE="debug python +threads"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

Expand All @@ -45,9 +45,9 @@ src_prepare() {

src_configure() {
local myeconfargs=(
--disable-static
$(use_enable debug)
$(use_enable python)
$(use_enable static-libs static)
$(use_enable threads)
)
econf "${myeconfargs[@]}"
Expand Down

0 comments on commit 69f45f3

Please sign in to comment.