Skip to content

Commit

Permalink
dev-lua/luafilesystem: version bump to 1.6.3.
Browse files Browse the repository at this point in the history
This commit:
* bumps ebuild EAPI to version 6.
* adds luajit support to luafilesystem.

Gentoo-Bug: https://bugs.gentoo.org/534150
Gentoo-Bug: https://bugs.gentoo.org/584492
Closes: gentoo#4263
  • Loading branch information
lluixhi authored and monsieurp committed May 1, 2017
1 parent 2b9c8ff commit 6a72293
Show file tree
Hide file tree
Showing 3 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/luafilesystem/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST luafilesystem-1.5.0.tar.gz 26660 SHA256 00f6e1dc1e1da7f0fa77e375f0a04908ec4241a4c5e8d98031614f4a4a50c7cb SHA512 79e767be5b923424c2f3c0025e050b6a5b15550cf96d153072f817b0f94757032feeaa579e4d73cc009a5954d38a30079db1c1c15545a45e9f13c0c776080aac WHIRLPOOL 67b3e3c82ddf0732afbd0c49dcff7608520742c7aca0aa38d709f282322d8b0487654c662327b68f3f451492e70ff5e9b485453090d792541a7aedf1efdc8fdf
DIST luafilesystem-1.6.2.tar.gz 27886 SHA256 4ad16df9958314662a459fec848d233d59313ef4992808a290053c1614532018 SHA512 75debecd3b35d43e76b51de02cface73808547be6a26e15c06c969c50bbfd7c4d0801ccb68812b7ecb99e56eaa63deeadaba6d0387748e215e5bdab784d463ff WHIRLPOOL 156fcb9b902fe8191925c12bbeaac14525c24ebbeff22bfb1bead3429090b074a29e41bf25d903692cf33fe53ca5983b3f935476e765b1ba0804e2113e026561
DIST luafilesystem-1.6.3.tar.gz 30389 SHA256 11c7b1fc2e560c0a521246b84e6257138d97dddde5a19e405714dbabcb9436ca SHA512 47a2637903c9d42ce3ab7cf3e27b6457845aeed7ce90c0fee964ba9bf9eabf6a6eea940f960713f6b982f1b64167dbd5da8f217281284143c89e3cc5488b8404 WHIRLPOOL 8400028a142e23f33d29dd260b096f62de84ac3d2f8429de74d34c56789e8e70cdd9698cae9550f8a18bc785e9fb705eca958e9bd89595513075ac4c155aa940
53 changes: 53 additions & 0 deletions dev-lua/luafilesystem/luafilesystem-1.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit toolchain-funcs

MY_PV=${PV//./_}

DESCRIPTION="File System Library for the Lua Programming Language"
HOMEPAGE="https://keplerproject.github.io/luafilesystem/"
SRC_URI="https://github.com/keplerproject/luafilesystem/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86 ~x86-fbsd"
IUSE="luajit"

RDEPEND="
!luajit? ( >=dev-lang/lua-5.1 )
luajit? ( dev-lang/luajit:2 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

HTML_DOCS=( doc/us )

S="${WORKDIR}/${PN}-${MY_PV}"

src_prepare() {
default

sed -i \
-e "s|-O2|${CFLAGS}|" \
-e "/^LIB_OPTION/s|= |= ${LDFLAGS} |" \
config || die
}

src_compile() {
emake \
CC=$(tc-getCC) \
INCS="-I$($(tc-getPKG_CONFIG) --variable includedir $(usex luajit 'luajit' 'lua'))"
}

src_test() {
LUA_CPATH=./src/?.so $(usex luajit 'luajit' 'lua') tests/test.lua
}

src_install() {
emake \
LUA_LIBDIR="${ED%/}$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD $(usex luajit 'luajit' 'lua'))" \
install

einstalldocs
}
4 changes: 4 additions & 0 deletions dev-lua/luafilesystem/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -11,4 +11,8 @@
LuaFileSystem offers a portable way to access the underlying directory
structure and file attributes.
</longdescription>
<use>
<flag name="luajit">Use <pkg>dev-lang/luajit</pkg> instead of
<pkg>dev-lang/lua</pkg></flag>
</use>
</pkgmetadata>

0 comments on commit 6a72293

Please sign in to comment.