Skip to content

Commit

Permalink
net-misc/dhcpcd: Change live ebuild to pull from git per upstream req…
Browse files Browse the repository at this point in the history
…uest

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
williamh committed Feb 24, 2017
1 parent 0334341 commit 6a9c88e
Showing 1 changed file with 3 additions and 25 deletions.
28 changes: 3 additions & 25 deletions net-misc/dhcpcd/dhcpcd-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,12 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

if [[ ${PV} == "9999" ]]; then
FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
EGIT_REPO_URI="git://roy.marples.name/dhcpcd"
inherit git-r3
else
MY_P="${P/_alpha/-alpha}"
MY_P="${MY_P/_beta/-beta}"
Expand All @@ -27,29 +28,6 @@ COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"

if [[ ${PV} == "9999" ]]; then
DEPEND+=" dev-vcs/fossil"

src_unpack()
{
local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
local repo=${distdir}/fossil/${PN}.fossil

addwrite "${distdir}"

if [[ -e "${repo}" ]]; then
fossil pull "${FOSSIL_URI}" -R "${repo}" || die
else
mkdir -p "${distdir}/fossil" || die
fossil clone "${FOSSIL_URI}" "${repo}" || die
fi

mkdir -p "${S}" || die
cd "${S}" || die
fossil open "${repo}" || die
}
fi

src_configure()
{
local dev hooks rundir
Expand Down

0 comments on commit 6a9c88e

Please sign in to comment.