Skip to content

Commit

Permalink
Revert "app-text/discount: drop old"
Browse files Browse the repository at this point in the history
This reverts commit dc7b43c.

Signed-off-by: Ben Kohler <[email protected]>
  • Loading branch information
benkohler committed Apr 20, 2020
1 parent befb51b commit 6ab8a01
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/discount/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST discount-2.2.4.tar.bz2 99482 BLAKE2B b04c372cef27d0a4a09a588eb66376dc70494eefe5c8a9e7aedb8075f081a6f32eafbb9671c29deea7d89128f4f30c93d38c17268eccbb1c917db6c1b7d3e040 SHA512 0650e0ce3f6948e3a30fdaa1a810e895f64621c55df46c7a5ed8755e65c1b718b7a1d1a1bfe0a87a3a59fbb13fca8907718f1aa095125a4b6e152602b8e490cf
DIST discount-2.2.6.tar.bz2 102303 BLAKE2B 6ffcb64ff8889d79832b28db9a824e5a30bd194a6746dd08e4782cb4b7e60cf47c44f244884fc10372fc2b052fff7d70e6c263e6f4175829d1aedbc8c2ea15c6 SHA512 b67395afed0899563e28fdd2ddd5016d4f382b6b7e46612d12853d701ba191b90771d40e1223e24e3fbf497cad01fdd2e1c67a6b2bf4f6cf082f3fbe981bd002
71 changes: 71 additions & 0 deletions app-text/discount/discount-2.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

DESCRIPTION="A Markdown-to HTML translator written in C"
HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 sparc x86"
IUSE="minimal test"
RESTRICT="!test? ( test )"

src_prepare() {
default

# for QA, we remove the Makefile’s usage of install -s.
# Drop ldconfig invocation.
# Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
# at that point).
sed -i \
-e '/INSTALL_PROGRAM/s,\$_strip ,,' \
-e 's/\(LDCONFIG=\).*/\1:/' \
-e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
configure.inc || die "sed configure.inc failed"

# Add LDFLAGS and CPPFLAGS hackily.
sed -i \
-e 's/^CC[ \t]*=.*/& $(CPPFLAGS)/' \
-e 's/^LFLAGS[ \t]*=.*/& $(LDFLAGS)/' \
Makefile.in || die "Cannot fix LDFLAGS and CPPFLAGS"
}

src_configure() {
local configure_call=(
./configure.sh
--libdir="${EPREFIX}"usr/"$(get_libdir)"
--prefix="${EPREFIX}"usr
--mandir="${EPREFIX}"usr/share/man
--shared
--pkg-config
$(usex minimal '' --enable-all-features)
# Enable deterministic HTML generation behavior. Otherwise, will
# actually call rand() as part of its serialization code...
--debian-glitch
)
einfo "Running ${configure_call[@]}"
CC="$(tc-getCC)" \
"${configure_call[@]}" || die
}

src_install() {
emake \
DESTDIR="${D}" \
$(usex minimal install install.everything) \
SAMPLE_PFX="${PN}-"

insinto /usr/$(get_libdir)/pkgconfig
doins libmarkdown.pc
}

pkg_postinst() {
if ! use minimal; then
elog 'Sample binaries with overly-generic names have been'
elog "prefixed with \"${PN}-\"."
fi
}

0 comments on commit 6ab8a01

Please sign in to comment.