forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-gfx/apngasm: version bump to 2.91
- Loading branch information
Showing
4 changed files
with
79 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST apngasm-2.5-src.zip 11333 SHA256 e5346948f2a51328161b3ef0d2c8111cd7289c7b4ac48e72db3a617cfb4f24c5 SHA512 6d5ff2968c3be94276db56809908c0dc4e8dea891453959c78bb23142f75b915d9e82a71c6f2b58aa268197d5725ea04b18a010272f7c6d41f2c3cfd2eadf740 WHIRLPOOL 00df2c24ea2325448f48ee7b0dff32c4cb0a086f3b69df833ed61eacc8e5fb1a6a7a186d37960ff7b8368355d9b41e176067074ea698e1b57d3950a364296cc5 | ||
DIST apngasm-2.6-src.zip 11350 SHA256 1d4b63e55c241c0db4a812e6cddea48586e4275b041a1e600154c2840f4ebb06 SHA512 b603bb91ad2c803abd18894ff95212f9cbed37a61fdefec60f06284e03bf274721b291f63ac8cf7d6c0cad516cb05f2ae7382f4aeb42ec87ebb07eaf29b27050 WHIRLPOOL 0e1c2684e3b36a062fb832077b29395a2198dca94c784c80d9e9c7de7542db3208a9e80e7529d6e28b2e46b32ff98534b96b62e683eba3a1b2d4515898446b95 | ||
DIST apngasm-2.7-src.zip 11448 SHA256 af42569666cab268a20a0754191396c9d48f4e01d6e8f93c3ae1164c3c821cc3 SHA512 28ec70a4ac02021ff85390ad6863aaca5451937209345128ecd5baf76bef9495168c3c4ee5d823afbeb569ca673328673a81b807e7985c3d5d1843c056af7810 WHIRLPOOL e2cd3c937af8010672cb3866903df084c52e37e7c05c0933f0e7bf2be69ee74a78c5367c463a07d2314e5d416c3616e6e218060298f349be0eab944d4e6af2eb | ||
DIST apngasm-2.91-src.zip 597267 SHA256 4534b82a7339a0fa250f13445ad6e83fe878db5f3223b8276339581e7344a987 SHA512 2415389a989f7a7ff7f3e1328f7920c7515c9a492c89ef216ff53db68fe2f1a674ff60d5f4bfd5a8c710f625456557ae7d5b25f486ac826e3113976cd9fc11dc WHIRLPOOL d43671c6324fac64ae3633f337cf470bf9e69bee1c25af7e5fa855d04028c2251303a15b5f497be3ce8b1b5e33d7fd918d05e4f7ae6cfebd8f3f2bb1d8bb91cd |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit flag-o-matic toolchain-funcs | ||
|
||
DESCRIPTION="create an APNG from multiple PNG files" | ||
HOMEPAGE="https://sourceforge.net/projects/apngasm/" | ||
SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip" | ||
|
||
LICENSE="ZLIB LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="7z zopfli" | ||
|
||
RDEPEND="media-libs/libpng:0=[apng] | ||
sys-libs/zlib | ||
zopfli? ( app-arch/zopfli )" | ||
DEPEND="${RDEPEND} | ||
app-arch/unzip" | ||
|
||
S=${WORKDIR} | ||
|
||
PATCHES=( "${FILESDIR}"/${P}-makefile.patch ) | ||
|
||
src_prepare() { | ||
default | ||
|
||
# remove bundled libs | ||
rm -r zopfli zlib libpng || die | ||
|
||
if use 7z; then | ||
append-cflags -DFEATURE_7ZIP | ||
else | ||
sed -i '/^SRC_DIRS\s\+=/s/7z//' Makefile || die | ||
fi | ||
|
||
if use zopfli; then | ||
append-cflags -DFEATURE_ZOPFLI | ||
sed -i '/^LIBS\s\+=/s/$/ -lzopfli/' Makefile || die | ||
fi | ||
} | ||
|
||
src_compile() { | ||
emake CC="$(tc-getCC)" | ||
} | ||
|
||
src_install() { | ||
dobin ${PN} | ||
dodoc readme.txt | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
--- apngasm-2.91-src/Makefile | ||
+++ apngasm-2.91-src/Makefile | ||
@@ -1,8 +1,7 @@ | ||
PACKAGE = apngasm | ||
CC = gcc | ||
-SRC_DIRS = . 7z zopfli | ||
-CFLAGS = -Wall -pedantic -DFEATURE_7ZIP -DFEATURE_ZOPFLI | ||
-CFLAGS_OPT = -O2 | ||
+SRC_DIRS = . 7z | ||
+CFLAGS += -Wall -pedantic | ||
CFLAGS_7Z = -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses | ||
LIBS = -lstdc++ -lm -lpng -lz | ||
|
||
@@ -16,7 +15,7 @@ | ||
all : $(PACKAGE) | ||
|
||
$(PACKAGE) : objdirs $(OBJECTS) | ||
- $(CC) -o $@ $(OBJECTS) -s $(LIBS) | ||
+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) $(LIBS) | ||
|
||
objdirs : | ||
mkdir -p $(OBJ_DIRS) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -5,6 +5,10 @@ | |
<email>[email protected]</email> | ||
<name>Gentoo Graphics Project</name> | ||
</maintainer> | ||
<use> | ||
<flag name="7z">Enable support for 7zip compression</flag> | ||
<flag name="zopfli">Enable support for Zopfli compression</flag> | ||
</use> | ||
<upstream> | ||
<remote-id type="sourceforge">apngasm</remote-id> | ||
</upstream> | ||
|