Skip to content

Commit

Permalink
app-office/gnumeric: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
pacho2 committed Oct 17, 2015
1 parent a4909bd commit 6b74078
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/gnumeric/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gnumeric-1.12.22.tar.xz 18541384 SHA256 3908cfd6520b599eefefe222aadeaa5126394b54d9a9a7f5e0f938eb674dcf47 SHA512 04accd723db1b88fab80c93234f584f99138ae9c04fe6809cac59d5d4be9f4c105c288f6607ac22f019e3388ad821461e2423405353a42d3936c067219683390 WHIRLPOOL e7a6270ec7e72f4d2c75bcef984b4db7fa3aea8f4fff29d34e8b949dfac354e855af23d02e7a316b5db744b883c72e3056b196c8c1af734a4f03686691cf22ba
DIST gnumeric-1.12.23.tar.xz 18515672 SHA256 00474cbf1e70f62062974d0beb5f65ebc45d1047bc8fd0a1133e3d9725e19551 SHA512 58f7667196cef453a24689640d21f7de20b052502fcd8f18c9abbe3ca6210d183e0bd53080ba0d6686f145400f404e75f4ed691c90801c5e2cb9f0168420cca0 WHIRLPOOL 7717082ce618adc32f20146aa86b355cbc235e8643fb7729d96c35230035cdebdf8b3aca6ba04fc53e47ce8124efe899129763384bd2172a27087482abedb30a
DIST gnumeric-1.12.24.tar.xz 18526768 SHA256 c59d5271b27366008bccb4d53ad8333da36d837003a018892f2da325c1449551 SHA512 71bed41a1b50ed57e9ab4993df8d963cb14a9f6f3fbf87d81c30f71359a23c4092daab00079936e587a118041a303c1c563bcd3f38f2aaea78a9ae5593dcdd4b WHIRLPOOL 648930de4d37d25db471fe9b639b91a64a1d1ebf1a50291ef2c79a23d4082b7249e6197467e86ce752e96699b38a7c3d86730cead7d0438c7e6605521b61e7b8
65 changes: 65 additions & 0 deletions app-office/gnumeric/gnumeric-1.12.24.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 )

inherit gnome2 flag-o-matic python-single-r1

DESCRIPTION="The GNOME Spreadsheet"
HOMEPAGE="http://www.gnumeric.org/"
LICENSE="GPL-2"

SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"

IUSE="+introspection libgda perl python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

# Missing gnome-extra/libgnomedb required version in tree
# but its upstream is dead and will be dropped soon.

# lots of missing files, also fails tests due to 80-bit long story
# upstream bug #721556
RESTRICT="test"

RDEPEND="
app-arch/bzip2
sys-libs/zlib
>=dev-libs/glib-2.38.0:2
>=gnome-extra/libgsf-1.14.33:=
>=x11-libs/goffice-0.10.22:0.10
>=dev-libs/libxml2-2.4.12:2
>=x11-libs/pango-1.24.0:=
>=x11-libs/gtk+-3.8.7:3
x11-libs/cairo:=[svg]
introspection? ( >=dev-libs/gobject-introspection-1:= )
perl? ( dev-lang/perl )
python? ( ${PYTHON_DEPS}
>=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
libgda? ( gnome-extra/libgda:5[gtk] )
"
DEPEND="${RDEPEND}
app-text/scrollkeeper
>=dev-util/intltool-0.35.0
virtual/pkgconfig
"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_configure() {
gnome2_src_configure \
--disable-static \
--with-zlib \
$(use_with libgda gda) \
$(use_enable introspection) \
$(use_with perl) \
$(use_with python)
}

0 comments on commit 6b74078

Please sign in to comment.