Skip to content

Commit

Permalink
dev-qt/*: add 6.6.9999
Browse files Browse the repository at this point in the history
Sraight copies from 6.9999, pending updates as-needed to prepare
for 6.6 which is slowly approaching (6.9999 been 6.7 for some time).

6.5.9999 will be leaving soon given 6.5.3 is the last 6.5 release
for plebians.

Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Sep 13, 2023
1 parent 33c8cbf commit 6ba6350
Show file tree
Hide file tree
Showing 26 changed files with 1,515 additions and 0 deletions.
36 changes: 36 additions & 0 deletions dev-qt/qt3d/qt3d-6.6.9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit qt6-build

DESCRIPTION="3D rendering module for the Qt6 framework"

if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
elif [[ ${QT6_BUILD_TYPE} == live ]]; then
EGIT_SUBMODULES=() # skip qtquick3d-assimp
fi

IUSE="gles2-only qml vulkan"

RDEPEND="
~dev-qt/qtbase-${PV}:6[concurrent,gles2-only=,gui,network,opengl,vulkan=]
~dev-qt/qtshadertools-${PV}:6
media-libs/assimp:=
qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
"
DEPEND="
${RDEPEND}
vulkan? ( dev-util/vulkan-headers )
"

src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Qml)
-DQT_FEATURE_qt3d_system_assimp=ON
)

qt6-build_src_configure
}
37 changes: 37 additions & 0 deletions dev-qt/qt5compat/qt5compat-6.6.9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit qt6-build

DESCRIPTION="Qt module containing the unsupported Qt 5 APIs"

if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi

IUSE="icu qml"

RDEPEND="
~dev-qt/qtbase-${PV}:6[gui,icu=,network,xml]
icu? ( dev-libs/icu:= )
qml? (
~dev-qt/qtdeclarative-${PV}:6
~dev-qt/qtshadertools-${PV}:6
)
"
DEPEND="${RDEPEND}"

src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Quick)
)

qt6-build_src_configure
}

src_test() {
# tst_qxmlinputsource sometimes hang without -j1
qt6-build_src_test -j1
}
Loading

0 comments on commit 6ba6350

Please sign in to comment.