Skip to content

Commit

Permalink
media-libs/gegl: 0.3.24
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.16, Repoman-2.3.6
  • Loading branch information
hartwork committed Dec 13, 2017
1 parent 4a101a8 commit 6ba85b8
Show file tree
Hide file tree
Showing 2 changed files with 178 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/gegl/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST gegl-0.2.0.tar.bz2 7502040 BLAKE2B 29b33bf6aa878b74461e929a96570fca9a56e52931ee66356ca9c3c4cec7cdc0668330aa25756d0baf531d0b90c4830c1f244e8327b238a63d68cb74d486e961 SHA512 16ef3f6852fd8efef2b6468a754342a2d003f2c2bef468d9465a448e6c89dedb8e791570f073a9faed05218a7c94c6c418eaa0f3abeadfb3e6b88d766ab792c8
DIST gegl-0.3.0.tar.bz2 5463571 BLAKE2B 7ac52fb22bab3b84068e10610d8681a5bcf56f6cdf39dae4374d2749823f3a1af62995382a1247427dde1921e0b11304adb800a2157ca6e7e773fdd97fee47f5 SHA512 ff758df4689b0fa8f5e16ebcea32a7fe77bccfef70efc20d10669ce5139a70ec3533e78227fd4798812b31ac1ca5081b9d1d701a7449bf75356f879ece5fadd6
DIST gegl-0.3.20.tar.bz2 5816967 BLAKE2B 4d1dea5b479dc56599d884c43dd8042f6c1c836fe3b5acdadc9b1a909ab4c4be549322767293cfbc065a5f9386b22a579c9c9d78fbad58a4eb6771eccf3a3b45 SHA512 9067467e3d4bbfe00594a8459c9ea15047c1331764dd3aa2331da7d842a77c98894e3a0e19a7c0b1cb59189ffe03561e9bd12f92bdb8fdf1799afc6a575962f7
DIST gegl-0.3.24.tar.bz2 6519831 BLAKE2B b6f9375de34b17270b92b7aeb0199f9c842813bc74175845ee8e8de8b48bc4d81d973282a1e398a39432c73c485cfb158b368989ecb40361f61f22620d53659a SHA512 c84950a4d2fddcb0fdcce77030841f862b1eeda72b31f115fb3604a52553414873923a321c48ed11a135113f40d026cf65425742663f23af79bfca2392eba9c5
DIST gegl-0.3.8.tar.bz2 5876259 BLAKE2B 24199148ffbef6454ea460d126c29f1cc8581e5430bc3e341a8ab48fff701a0d63c4cf8864d04219455feaeb7e03808e8de06cc8ae0a500eb4154f2ec9ba25fe SHA512 13207e7ab4723be1e31bdba5e30e5725e93c1adc61bad1413502128730391dbe7eb35419d243c8d0a1d8794341a58188790adacbb10d2a8e68db861c18d21bfb
177 changes: 177 additions & 0 deletions media-libs/gegl/gegl-0.3.24.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,177 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 )

# vala and introspection support is broken, bug #468208
VALA_USE_DEPEND=vapigen

inherit versionator gnome2-utils eutils autotools python-any-r1 vala

if [[ ${PV} == *9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="git://git.gnome.org/gegl"
SRC_URI=""
else
SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="A graph based image processing framework"
HOMEPAGE="http://www.gegl.org/"

LICENSE="|| ( GPL-3 LGPL-3 )"
SLOT="0.3"

IUSE="cairo cpu_flags_x86_mmx cpu_flags_x86_sse debug ffmpeg +introspection jpeg2k lcms lensfun openexr raw sdl svg test tiff umfpack vala v4l webp"
REQUIRED_USE="
svg? ( cairo )
vala? ( introspection )
"

# NOTE: Even current libav 11.4 does not have AV_CODEC_CAP_VARIABLE_FRAME_SIZE
# so there is no chance to support libav right now (Gentoo bug #567638)
# If it returns, please check prior GEGL ebuilds for how libav was integrated. Thanks!
RDEPEND="
>=dev-libs/glib-2.44:2
dev-libs/json-glib
>=media-libs/babl-0.1.38
sys-libs/zlib
>=x11-libs/gdk-pixbuf-2.32:2
x11-libs/pango
cairo? ( >=x11-libs/cairo-1.12.2 )
ffmpeg? (
>=media-video/ffmpeg-2.8:0=
)
introspection? ( >=dev-libs/gobject-introspection-1.32:= )
virtual/jpeg:0=
jpeg2k? ( >=media-libs/jasper-1.900.1:= )
lcms? ( >=media-libs/lcms-2.8:2 )
lensfun? ( >=media-libs/lensfun-0.2.5 )
openexr? ( >=media-libs/openexr-1.6.1:= )
>=media-libs/libpng-1.6.0:0=
raw? ( >=media-libs/libraw-0.15.4:0= )
sdl? ( >=media-libs/libsdl-1.2.0 )
svg? ( >=gnome-base/librsvg-2.40.6:2 )
tiff? ( >=media-libs/tiff-4:0 )
umfpack? ( sci-libs/umfpack )
v4l? ( >=media-libs/libv4l-1.0.1 )
webp? ( >=media-libs/libwebp-0.5.0:= )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1
>=sys-devel/gettext-0.19.8
dev-lang/perl
virtual/pkgconfig
>=sys-devel/libtool-2.2
test? ( introspection? (
$(python_gen_any_dep '>=dev-python/pygobject-3.2[${PYTHON_USEDEP}]') ) )
vala? ( $(vala_depend) )
"

pkg_setup() {
use test && use introspection && python-any-r1_pkg_setup
}

src_prepare() {
default

# FIXME: the following should be proper patch sent to upstream
# fix OSX loadable module filename extension
sed -i -e 's/\.dylib/.bundle/' configure.ac || die
# don't require Apple's OpenCL on versions of OSX that don't have it
if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -le 9 ]] ; then
sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
fi

# commit 7c78497b : tests that use gegl.png are broken on non-amd64
sed -e '/clones.xml/d' \
-e '/composite-transform.xml/d' \
-i tests/compositions/Makefile.am || die

epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch

eautoreconf

gnome2_environment_reset

use vala && vala_src_prepare
}

src_configure() {
# never enable altering of CFLAGS via profile option
# libspiro: not in portage main tree
# disable documentation as the generating is bit automagic
# if anyone wants to work on it just create bug with patch

# Also please note that:
#
# - Some auto-detections are not patched away since the docs are
# not built (--disable-docs, lack of --enable-gtk-doc) and these
# tools affect re-generation of docs, only
# (e.g. ruby, asciidoc, dot (of graphviz), enscript)
#
# - Parameter --with-exiv2 compiles a noinst-app only, no use
#
# - Parameter --disable-workshop disables any use of Lua, effectivly
#
# - v4l support does not work with our media-libs/libv4l-0.8.9,
# upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
#
# - There are two checks for dot, one controllable by --with(out)-graphviz
# which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
#
# - mrg is not in tree and gexiv2 support only has effect when mrg support
# is enabled
#
# So that's why USE="exif graphviz lua v4l" got resolved. More at:
# https://bugs.gentoo.org/show_bug.cgi?id=451136
#
econf \
--disable-docs \
--disable-profile \
--disable-silent-rules \
--disable-workshop \
--program-suffix=-${SLOT} \
--with-gdk-pixbuf \
--with-pango \
--without-libspiro \
$(use_enable cpu_flags_x86_mmx mmx) \
$(use_enable cpu_flags_x86_sse sse) \
$(use_enable debug) \
$(use_with cairo) \
$(use_with cairo pangocairo) \
--without-exiv2 \
$(use_with ffmpeg libavformat) \
--without-gexiv2 \
--without-graphviz \
$(use_with jpeg2k jasper) \
$(use_with lcms) \
$(use_with lensfun) \
--without-lua \
--without-mrg \
$(use_with openexr) \
$(use_with raw libraw) \
$(use_with sdl) \
$(use_with svg librsvg) \
$(use_with tiff libtiff) \
$(use_with umfpack) \
$(use_with v4l libv4l) \
$(use_with v4l libv4l2) \
$(use_enable introspection) \
$(use_with vala) \
$(use_with webp)
}

src_compile() {
default

[[ ${PV} == *9999* ]] && emake ./ChangeLog # "./" prevents "Circular ChangeLog <- ChangeLog dependency dropped."
}

src_install() {
default
prune_libtool_files --all
}

0 comments on commit 6ba85b8

Please sign in to comment.