Skip to content

Commit

Permalink
games-arcade/openmortal: Use pkg-config to find freetype
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/655036
Package-Manager: Portage-2.3.36, Repoman-2.3.9
  • Loading branch information
Lars Wendler committed May 7, 2018
1 parent 810913d commit 6bef359
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
--- openmortal-0.7/configure.in
+++ openmortal-0.7/configure.in
@@ -25,6 +25,7 @@
AC_C_CONST
AC_PROG_CXX

+PKG_PROG_PKG_CONFIG

dnl
dnl Switches
@@ -122,11 +123,8 @@

dnl Check for Freetype 2 library

-FT2_VERSION=2.1.0
-AC_CHECK_FT2(
- $FT2_VERSION,
- :,
- AC_MSG_ERROR([*** FreeType 2 version $FT2_VERSION not found!])
+PKG_CHECK_MODULES(FT2, freetype2,,
+ AC_MSG_ERROR([*** FreeType2 not found!])
)
CXXFLAGS="$CXXFLAGS $FT2_CFLAGS"
LIBS="$LIBS $FT2_LIBS"
8 changes: 5 additions & 3 deletions games-arcade/openmortal/openmortal-0.7-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -13,21 +13,23 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="media-libs/libsdl[video]
RDEPEND="media-libs/libsdl[video]
media-libs/sdl-image
media-libs/sdl-mixer
media-libs/sdl-ttf
media-libs/sdl-net
>=media-libs/freetype-2.4.0:2
dev-lang/perl
"
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
virtual/pkgconfig"

src_prepare() {
default
eapply \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}/${P}"-freetype.patch
"${FILESDIR}/${P}"-freetype.patch \
"${FILESDIR}/${P}"-freetype_pkgconfig.patch
mv configure.{in,ac} || die
eautoreconf
}
Expand Down

0 comments on commit 6bef359

Please sign in to comment.