Skip to content

Commit

Permalink
dev-haskell/wavy: tweak for ghc-8.8
Browse files Browse the repository at this point in the history
Reported-by: Agostino Sarubbo
Closes: https://bugs.gentoo.org/736444
Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Aug 9, 2020
1 parent 3bef503 commit 6bfd43b
Show file tree
Hide file tree
Showing 2 changed files with 17 additions and 3 deletions.
11 changes: 11 additions & 0 deletions dev-haskell/wavy/files/wavy-0.1.0.0-ghc-8.8.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/Sound/Wav/ChannelData.hs
+++ b/Sound/Wav/ChannelData.hs
@@ -111,7 +111,7 @@ wordPutter 1 = putInt8 . zeroStable (0 :: Int8)
wordPutter 2 = putInt16le . zeroStable (0 :: Int16)
wordPutter 3 = putInt32le . zeroStable (0 :: Int32)
wordPutter 4 = putInt64le
-wordPutter x = \_ -> fail $ "The is no word putter for byte size " ++ show x
+wordPutter x = \_ -> error $ "The is no word putter for byte size " ++ show x

wordGetter :: (Num a, Show a, Eq a) => a -> Get Int64
wordGetter 1 = fmap zeroStable64 getInt8
9 changes: 6 additions & 3 deletions dev-haskell/wavy/wavy-0.1.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -9,7 +9,7 @@ CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal

DESCRIPTION="Process WAVE files in Haskell"
HOMEPAGE="https://bitbucket.org/robertmassaioli/wavy"
HOMEPAGE="http://bitbucket.org/robertmassaioli/wavy"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"

LICENSE="BSD"
Expand All @@ -27,7 +27,10 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
"

PATCHES=("${FILESDIR}"/${P}-binary-0.8.patch)
PATCHES=(
"${FILESDIR}"/${P}-binary-0.8.patch
"${FILESDIR}"/${P}-ghc-8.8.patch
)

src_prepare() {
default
Expand Down

0 comments on commit 6bfd43b

Please sign in to comment.