Skip to content

Commit

Permalink
sys-fs/zfs (and friends): version bump to 0.7.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.21, Repoman-2.3.6
  • Loading branch information
Jonathan Vasquez committed Feb 9, 2018
1 parent 98c9e48 commit 6cecc8f
Show file tree
Hide file tree
Showing 6 changed files with 461 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/zfs-kmod/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST zfs-0.6.5.11.tar.gz 2521959 BLAKE2B 95b145a26620995343df1a468367b882bc71ab3
DIST zfs-0.6.5.4-patches-p1.tar.xz 64004 BLAKE2B e9db3c1bde3a2636b35a4204c484bc4cec0968278519762707849ba138eeb9128130de70c2f40bb28dc9102347465d724a60cebd45ddb12d4217739ecbed7714 SHA512 9203356b43bdad2ed78c946af8c95c9fc4d2996b41a09a3b1f5a8657d2742ac69d10b4a87d443db497d591878cf7a70ebb19762b0df135ee25f4e8d2ed6ad71f
DIST zfs-0.6.5.4.tar.gz 2506470 BLAKE2B 10a2242081891b94a7863f11b4c3b9e443d3b75b5eb03e8fc88e30484a94555203dec8964075cf23f694777dd699e20acb1a52b5d04cba410b6df84512436e08 SHA512 90c87cd95fd06cf34755358e7cc4053d19f351316133f0b808e7585a3fc8f82e7c0f49072c2995d0520de5104fd04d91a166a0d5b6c923c82dfb2fb4f7f57a01
DIST zfs-0.7.5.tar.gz 6403102 BLAKE2B 5159b2ab811b2f7bcbbc708814e07e68b0b38d7b5fca4a82205c7bb4332155121f1385f2cd3a6b7acb6bd64d13b9ad2af85d42b90623efb0f33a2f542fb90803 SHA512 3512aaa6225f74323f2d14e029a113593e0cf44be2ab18cc42dcb82d237b88843ccd7e48ed73a4c6f6da574151c1af461e0528725e11bcb42280467e37f63df2
DIST zfs-0.7.6.tar.gz 6409035 BLAKE2B 498d02172f0eaaa658e2aad2dd74d37f0ce5d41fda817976cc370ad42ad320f09124e6dc4a609b5eeda7819f538247cf64823871d00902e80a9bc92a374d0d51 SHA512 d9d45696b81080234068a4731276f888382e6680a6ca30d302110dbd1fa00d38ef17bd59de4b787b1ce91c3184ccb403c5db6b064a611f6f8572fa077a989cdb
145 changes: 145 additions & 0 deletions sys-fs/zfs-kmod/zfs-kmod-0.7.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,145 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

if [ ${PV} == "9999" ]; then
AUTOTOOLS_AUTORECONF="1"
EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
inherit git-r3
else
SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${PV}/zfs-${PV}.tar.gz"
S="${WORKDIR}/zfs-${PV}"
KEYWORDS="~amd64"
fi

inherit flag-o-matic linux-info linux-mod toolchain-funcs autotools-utils

DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
HOMEPAGE="http://zfsonlinux.org/"

LICENSE="CDDL debug? ( GPL-2+ )"
SLOT="0"
IUSE="custom-cflags debug +rootfs"
RESTRICT="debug? ( strip ) test"

DEPEND="
=sys-kernel/spl-${PV}*
dev-lang/perl
virtual/awk
"

RDEPEND="${DEPEND}
!sys-fs/zfs-fuse
"

AT_M4DIR="config"
AUTOTOOLS_IN_SOURCE_BUILD="1"

DOCS=( AUTHORS COPYRIGHT DISCLAIMER README.markdown )

pkg_setup() {
linux-info_pkg_setup
CONFIG_CHECK="
!DEBUG_LOCK_ALLOC
EFI_PARTITION
IOSCHED_NOOP
MODULES
!PAX_KERNEXEC_PLUGIN_METHOD_OR
ZLIB_DEFLATE
ZLIB_INFLATE
"

use debug && CONFIG_CHECK="${CONFIG_CHECK}
FRAME_POINTER
DEBUG_INFO
!DEBUG_INFO_REDUCED
"

use rootfs && \
CONFIG_CHECK="${CONFIG_CHECK}
BLK_DEV_INITRD
DEVTMPFS
"

kernel_is ge 2 6 32 || die "Linux 2.6.32 or newer required"

[ ${PV} != "9999" ] && \
{ kernel_is le 4 15 || die "Linux 4.15 is the latest supported version."; }

check_extra_config
}

src_prepare() {
# Remove GPLv2-licensed ZPIOS unless we are debugging
use debug || sed -e 's/^subdir-m += zpios$//' -i "${S}/module/Makefile.in"

# Set module revision number
[ ${PV} != "9999" ] && \
{ sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" "${S}/META" || die "Could not set Gentoo release"; }

autotools-utils_src_prepare
}

src_configure() {
local SPL_PATH="$(basename $(echo "${EROOT}usr/src/spl-"*))"
use custom-cflags || strip-flags
filter-ldflags -Wl,*

set_arch_to_kernel
local myeconfargs=(${myeconfargs}
--bindir="${EPREFIX}/bin"
--sbindir="${EPREFIX}/sbin"
--with-config=kernel
--with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT_DIR}"
--with-spl="${EROOT}usr/src/${SPL_PATH}"
--with-spl-obj="${EROOT}usr/src/${SPL_PATH}/${KV_FULL}"
$(use_enable debug)
)

autotools-utils_src_configure
}

src_install() {
autotools-utils_src_install INSTALL_MOD_PATH="${INSTALL_MOD_PATH:-$EROOT}"
}

pkg_postinst() {
linux-mod_pkg_postinst

# Remove old modules
if [ -d "${EROOT}lib/modules/${KV_FULL}/addon/zfs" ]
then
ewarn "${PN} now installs modules in ${EROOT}lib/modules/${KV_FULL}/extra/zfs"
ewarn "Old modules were detected in ${EROOT}lib/modules/${KV_FULL}/addon/zfs"
ewarn "Automatically removing old modules to avoid problems."
rm -r "${EROOT}lib/modules/${KV_FULL}/addon/zfs" || die "Cannot remove modules"
rmdir --ignore-fail-on-non-empty "${EROOT}lib/modules/${KV_FULL}/addon"
fi

if use x86 || use arm
then
ewarn "32-bit kernels will likely require increasing vmalloc to"
ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
fi

ewarn "This version of ZFSOnLinux includes support for new feature flags"
ewarn "that are incompatible with previous versions. GRUB2 support for"
ewarn "/boot with the new feature flags is not yet available."
ewarn "Do *NOT* upgrade root pools to use the new feature flags."
ewarn "Any new pools will be created with the new feature flags by default"
ewarn "and will not be compatible with older versions of ZFSOnLinux. To"
ewarn "create a newpool that is backward compatible wih GRUB2, use "
ewarn
ewarn "zpool create -d -o feature@async_destroy=enabled "
ewarn " -o feature@empty_bpobj=enabled -o feature@lz4_compress=enabled"
ewarn " -o feature@spacemap_histogram=enabled"
ewarn " -o feature@enabled_txg=enabled "
ewarn " -o feature@extensible_dataset=enabled -o feature@bookmarks=enabled"
ewarn " ..."
ewarn
ewarn "GRUB2 support will be updated as soon as either the GRUB2"
ewarn "developers do a tag or the Gentoo developers find time to backport"
ewarn "support from GRUB2 HEAD."
}
1 change: 1 addition & 0 deletions sys-fs/zfs/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST zfs-0.6.5.11.tar.gz 2521959 BLAKE2B 95b145a26620995343df1a468367b882bc71ab3
DIST zfs-0.6.5.4-patches-p2.tar.xz 63912 BLAKE2B f8bd5d0cd2b6170b45cf40a78b484d9a73017b20a77c603f4bcec63b6c77347b07df74c9d53288b5b2b984135d651d3d3ef830395ff2625576b13d8ce433fbcb SHA512 9f598c2a750b92dadddb677a6a9dda4573fa91421a82270d8104d718da4b945a4d5412bab92037a033cec1ec177f2a0eb52207babd023847918e3754054ec5e9
DIST zfs-0.6.5.4.tar.gz 2506470 BLAKE2B 10a2242081891b94a7863f11b4c3b9e443d3b75b5eb03e8fc88e30484a94555203dec8964075cf23f694777dd699e20acb1a52b5d04cba410b6df84512436e08 SHA512 90c87cd95fd06cf34755358e7cc4053d19f351316133f0b808e7585a3fc8f82e7c0f49072c2995d0520de5104fd04d91a166a0d5b6c923c82dfb2fb4f7f57a01
DIST zfs-0.7.5.tar.gz 6403102 BLAKE2B 5159b2ab811b2f7bcbbc708814e07e68b0b38d7b5fca4a82205c7bb4332155121f1385f2cd3a6b7acb6bd64d13b9ad2af85d42b90623efb0f33a2f542fb90803 SHA512 3512aaa6225f74323f2d14e029a113593e0cf44be2ab18cc42dcb82d237b88843ccd7e48ed73a4c6f6da574151c1af461e0528725e11bcb42280467e37f63df2
DIST zfs-0.7.6.tar.gz 6409035 BLAKE2B 498d02172f0eaaa658e2aad2dd74d37f0ce5d41fda817976cc370ad42ad320f09124e6dc4a609b5eeda7819f538247cf64823871d00902e80a9bc92a374d0d51 SHA512 d9d45696b81080234068a4731276f888382e6680a6ca30d302110dbd1fa00d38ef17bd59de4b787b1ce91c3184ccb403c5db6b064a611f6f8572fa077a989cdb
202 changes: 202 additions & 0 deletions sys-fs/zfs/zfs-0.7.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,202 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
PYTHON_COMPAT=( python{2_7,3_4,3_5} )

if [ ${PV} == "9999" ] ; then
inherit git-r3 linux-mod
AUTOTOOLS_AUTORECONF="1"
EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
else
SRC_URI="https://github.com/zfsonlinux/${PN}/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~amd64"
fi

inherit autotools-utils bash-completion-r1 flag-o-matic linux-info python-r1 systemd toolchain-funcs udev

DESCRIPTION="Userland utilities for ZFS Linux kernel module"
HOMEPAGE="http://zfsonlinux.org/"

LICENSE="BSD-2 CDDL MIT"
SLOT="0"
IUSE="custom-cflags debug kernel-builtin +rootfs test-suite static-libs"
RESTRICT="test"

COMMON_DEPEND="
net-libs/libtirpc
sys-apps/util-linux[static-libs?]
sys-libs/zlib[static-libs(+)?]
virtual/awk
"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
"

RDEPEND="${COMMON_DEPEND}
!=sys-apps/grep-2.13*
!kernel-builtin? ( =sys-fs/zfs-kmod-${PV}* )
!sys-fs/zfs-fuse
!prefix? ( virtual/udev )
test-suite? (
sys-apps/util-linux
sys-devel/bc
sys-block/parted
sys-fs/lsscsi
sys-fs/mdadm
sys-process/procps
virtual/modutils
)
rootfs? (
app-arch/cpio
app-misc/pax-utils
!<sys-boot/grub-2.00-r2:2
!<sys-kernel/genkernel-3.5.1.1
!<sys-kernel/genkernel-next-67
!<sys-kernel/bliss-initramfs-7.1.0
!<sys-kernel/dracut-044-r1
)
sys-fs/udev-init-scripts
"

AT_M4DIR="config"
AUTOTOOLS_IN_SOURCE_BUILD="1"

pkg_setup() {
if use kernel_linux && use test-suite; then
linux-info_pkg_setup
if ! linux_config_exists; then
ewarn "Cannot check the linux kernel configuration."
else
# recheck that we don't have usblp to collide with libusb
if use test-suite; then
if linux_chkconfig_present BLK_DEV_LOOP; then
eerror "The ZFS test suite requires loop device support enabled."
eerror "Please enable it:"
eerror " CONFIG_BLK_DEV_LOOP=y"
eerror "in /usr/src/linux/.config or"
eerror " Device Drivers --->"
eerror " Block devices --->"
eerror " [ ] Loopback device support"
fi
fi
fi
fi

}

src_prepare() {
# Update paths
sed -e "s|/sbin/lsmod|/bin/lsmod|" \
-e "s|/usr/bin/scsi-rescan|/usr/sbin/rescan-scsi-bus|" \
-e "s|/sbin/parted|/usr/sbin/parted|" \
-i scripts/common.sh.in

autotools-utils_src_prepare
}

src_configure() {
use custom-cflags || strip-flags
local myeconfargs=(
--bindir="${EPREFIX}/bin"
--sbindir="${EPREFIX}/sbin"
--with-config=user
--with-dracutdir="/usr/$(get_libdir)/dracut"
--with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT_DIR}"
--with-udevdir="$(get_udevdir)"
--with-blkid
$(use_enable debug)
)
autotools-utils_src_configure

# prepare systemd unit and helper script
cat "${FILESDIR}/zfs.service.in" | \
sed -e "s:@sbindir@:${EPREFIX}/sbin:g" \
-e "s:@sysconfdir@:${EPREFIX}/etc:g" \
> "${T}/zfs.service" || die
cat "${FILESDIR}/zfs-init.sh.in" | \
sed -e "s:@sbindir@:${EPREFIX}/sbin:g" \
-e "s:@sysconfdir@:${EPREFIX}/etc:g" \
> "${T}/zfs-init.sh" || die
}

src_install() {
autotools-utils_src_install
gen_usr_ldscript -a uutil nvpair zpool zfs zfs_core
use test-suite || rm -rf "${ED}usr/share/zfs"

newbashcomp "${FILESDIR}/bash-completion-r1" zfs
bashcomp_alias zfs zpool

exeinto /usr/libexec
doexe "${T}/zfs-init.sh"
systemd_dounit "${T}/zfs.service"
}

pkg_postinst() {
if ! use kernel-builtin && [ ${PV} = "9999" ]
then
einfo "Adding ${P} to the module database to ensure that the"
einfo "kernel modules and userland utilities stay in sync."
update_moduledb
fi

if [ -e "${EROOT}etc/runlevels/boot/zfs" ]
then
einfo 'The zfs boot script has been split into the zfs-import,'
einfo 'zfs-mount and zfs-share scripts.'
einfo
einfo 'You had the zfs script in your boot runlevel. For your'
einfo 'convenience, it has been automatically removed and the three'
einfo 'scripts that replace it have been configured to start.'
einfo 'The zfs-import and zfs-mount scripts have been added to the boot'
einfo 'runlevel while the zfs-share script is in the default runlevel.'

rm "${EROOT}etc/runlevels/boot/zfs"
ln -snf "${EROOT}etc/init.d/zfs-import" \
"${EROOT}etc/runlevels/boot/zfs-import"
ln -snf "${EROOT}etc/init.d/zfs-mount" \
"${EROOT}etc/runlevels/boot/zfs-mount"
ln -snf "${EROOT}etc/init.d/zfs-share" \
"${EROOT}etc/runlevels/default/zfs-share"
else
[ -e "${EROOT}etc/runlevels/boot/zfs-import" ] || \
einfo "You should add zfs-import to the boot runlevel."
[ -e "${EROOT}etc/runlevels/boot/zfs-mount" ] || \
einfo "You should add zfs-mount to the boot runlevel."
[ -e "${EROOT}etc/runlevels/default/zfs-share" ] || \
einfo "You should add zfs-share to the default runlevel."
fi

if [ -e "${EROOT}etc/runlevels/default/zed" ]
then
einfo 'The downstream OpenRC zed script has replaced by the upstream'
einfo 'OpenRC zfs-zed script.'
einfo
einfo 'You had the zed script in your default runlevel. For your'
einfo 'convenience, it has been automatically removed and the zfs-zed'
einfo 'script that replaced it has been configured to start.'

rm "${EROOT}etc/runlevels/boot/zed"
ln -snf "${EROOT}etc/init.d/zfs-sed" \
"${EROOT}etc/runlevels/default/zfs-zed"
else
[ -e "${EROOT}etc/runlevels/default/zfs-zed" ] || \
einfo "You should add zfs-zed to the default runlevel."
fi

if [ -e "${EROOT}etc/runlevels/shutdown/zfs-shutdown" ]
then
einfo "The zfs-shutdown script is obsolete. Removing it from runlevel."
rm "${EROOT}etc/runlevels/shutdown/zfs-shutdown"
fi

}

pkg_postrm() {
if ! use kernel-builtin && [ ${PV} = "9999" ]
then
remove_moduledb
fi
}
1 change: 1 addition & 0 deletions sys-kernel/spl/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST spl-0.6.5.11.tar.gz 531710 BLAKE2B e89cb5a023d3f4b3949a385100b56e01c5fd0ff4
DIST spl-0.6.5.4-patches-p1.tar.xz 2020 BLAKE2B 82b836df5c18f68ebd967d5d33e65232167ff1c4b1da3998dadf49c1fd0ffad4a86fa418a30ba0ba106ee4baa190fc51dedabec68083af80e5eb5aa1b225dcc5 SHA512 2650f06bf23045bd2805ef58baa2561534373862e1fbbaf189cf93283aa8e18cbee989b4e81751b37da3058aeba357cf8e46db97331379e1b5eafde7faa33851
DIST spl-0.6.5.4.tar.gz 556298 BLAKE2B 142d92ece51f544ed53f8d15390a97469b322c0e8f16c6510eb72f69493a3489f98ead9fa4138765b364c22777ee0cb49a76c4d9b1c4ac4e5ce8c0e5dbfe9952 SHA512 a50d804008237820d6a8e7d938f6699df2966836ebedf0b6a4421f55bd6c24ae69e8f80eaf3aa2b7f6ed308983ab4ca11abfb32f98c8d070e4957b4802e00cac
DIST spl-0.7.5.tar.gz 549272 BLAKE2B b645c68fa53e3e10a80788684efbeeafecb04753a1b515de32555943f372fa61c1c24cd7afac1cc646de572daa32f88c5b95662797a085c756519e03fdf3e46f SHA512 a797ddab6841cbe9c7eacc4f276537ecb5905a694604185044e98ed017b325367a1fdd1ea6830d29d4a21ed11a8d1ff0505bda7bbd2112418db319df128141a3
DIST spl-0.7.6.tar.gz 550089 BLAKE2B c0b1cc87a9b7997f6346a106eb8f23493938357fce9d6209e159016f2df5655678fce5ddc64dc4a63a4f93b715c44d5ff7fd30097c63ab62a1daabb3dcc28908 SHA512 b8e74e4ad8c16df1a4742639f00c4c4162607d136145bae58489f9a34539dcc5569da18639a67ac5d9d52b5feac93e052323ebf6efce6a92ba9a2b965f940fdd
Loading

0 comments on commit 6cecc8f

Please sign in to comment.