forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-fonts/ricty: Fix ricty font. Fixes bug 549828.
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,3 @@ | ||
DIST Ricty-3.2.0.tar.gz 13286 SHA256 bb2bf6d7762b5e6e13d237bd82ba43d6faffc17b7e6d541db89d58a73a8a319e | ||
DIST Ricty-3.2.0.tar.gz 13286 SHA256 bb2bf6d7762b5e6e13d237bd82ba43d6faffc17b7e6d541db89d58a73a8a319e SHA512 77b7416e8c2e6847ec4c964dda8e4fa52ba3e63751ce030fbd0cd83a07a88c777319690777e48e945d36ebf06fe4717d10a7e02193f48575507c5c1f71446b36 WHIRLPOOL cc86cd4da191941ea13bf3900ff78e2b0cd2c4825e79d23b0b00543ca3180fbc8afdc0fc94876d0ed89cc7de0c9ff8332b4877551f06f98a70cd5a96fa2aef47 | ||
EBUILD ricty-3.2.0-r1.ebuild 1065 SHA256 c1ea98f965c9a016475558b70168d73582e112cf10888585161726a5a68d8523 SHA512 6186b5abe1de7202070023475f28ac5bc66d224a4353a700af31a29ec117d5c606bf14993b4e2185e68eccf162f820470d8df08ae2425463967fd27000c0fb98 WHIRLPOOL 09c0bcb3e9a7954954072bce75b90117dd9ebad4a6189695850110cfe106b2c73e846da380cd428331a9e34275d57435cd5b91e3d1482b9cb1feb70edc0a96ff |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2012 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=4 | ||
inherit font | ||
|
||
MY_PN="Ricty" | ||
DESCRIPTION="A beautiful sans-serif monotype Japanese font designed for code listings" | ||
HOMEPAGE="http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty.html" | ||
#SRC_URI="http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty/${MY_PN}-${PV}.tar.gz" | ||
SRC_URI="https://github.com/yascentur/${MY_PN}/tarball/${PV} -> ${MY_PN}-${PV}.tar.gz" | ||
|
||
LICENSE="public-domain" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~x86-fbsd" | ||
IUSE="" | ||
|
||
DEPEND="media-fonts/inconsolata | ||
>=media-fonts/mix-mplus-ipa-20111002 | ||
media-gfx/fontforge" | ||
RDEPEND="" | ||
|
||
#S="${WORKDIR}/yascentur-${MY_PN}-*" | ||
S="${WORKDIR}/yascentur-${MY_PN}-b9d8b9c" | ||
|
||
FONT_SUFFIX="ttf" | ||
FONT_S="${S}" | ||
|
||
# Only installs fonts. | ||
RESTRICT="strip binchecks" | ||
|
||
src_compile() { | ||
sh ricty_generator.sh \ | ||
"${EPREFIX}/usr/share/fonts/inconsolata/Inconsolata-Regular.ttf" \ | ||
"${EPREFIX}/usr/share/fonts/mix-mplus-ipa/migu-1m-regular.ttf" \ | ||
"${EPREFIX}/usr/share/fonts/mix-mplus-ipa/migu-1m-bold.ttf" || die | ||
} |