Skip to content

Commit

Permalink
www-client/microsoft-edge-beta: bump to 92.0.902.22
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.2
Signed-off-by: Stephan Hartmann <[email protected]>
  • Loading branch information
stha09 committed Jun 22, 2021
1 parent 82ff855 commit 6d7bb0e
Show file tree
Hide file tree
Showing 2 changed files with 106 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/microsoft-edge-beta/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST microsoft-edge-beta_91.0.864.41-1_amd64.deb 99832786 BLAKE2B a7f26c9a92adc4deba1c04d6ee26bedb5360824aed48b397dfaf66cd3f524b9efbbc77c0191f52ae40d70e0ea9f1ca4943e58dc20f8ad7e40bcabb1636a02a8a SHA512 119a5c3cd2065b578705a76983e4d670427f2de356b529a22186c6e77b159f6d35e2e4195ea93f84d17b4469a1da5744b6957cbde0748e9421422b3fcc02a22a
DIST microsoft-edge-beta_92.0.902.15-1_amd64.deb 101256948 BLAKE2B 6fea611d12041d3d575b1b86c70ee693330dd6e4f6b2b476228aabffe6fba62140d373b4c7d9654e75f3cb86343f712413d4374e88a2310b30270f87f78db2bc SHA512 64d36b08a68abee0126128ec7595f31c8ecbd5200a2fc86c83c3ecd2f1dc2bb870feda66018b512d5f7a7c2a3b8e29a1b22ea1f90d5ae591baae96d4f9923ca0
DIST microsoft-edge-beta_92.0.902.22-1_amd64.deb 101892898 BLAKE2B 706b1dcc4b2f419f62fa578672bce71fb75809f06ff36938d33f1434697b8f72c9eb07d3b9dcf99a84a9739566a35ba8a921cef1dbee64e3a4509f4290dd1321 SHA512 fc4cbf6ec062acca48efef3cbbc1ceec4bfcc92bcc79d243e4ede658e394660b514687f5d73d1940fbc962c59e9d9bf271e6226bfd164978e54dc9974341d980
DIST microsoft-edge-beta_92.0.902.9-1_amd64.deb 101093516 BLAKE2B 061de15a6357696de55b5f56ae5d0e5c4aa2b9825184d25d8f7ca994315ed02a5ecb6b7b34a1a470348724d45e8eabbf1efa3d67defed1dd869d81de16b82a8e SHA512 48bc0ba4cb87c6eba4b4923e4f26cc54fc74051252b0f682719e5af7eb124bcfed4c6e99b5a5df110523de29681f74aee2530dd3e19bc740b8669cc9a5d7d023
105 changes: 105 additions & 0 deletions www-client/microsoft-edge-beta/microsoft-edge-beta-92.0.902.22.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,105 @@
# Copyright 2011-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit chromium-2 desktop pax-utils unpacker xdg

DESCRIPTION="The web browser from Microsoft"
HOMEPAGE="https://www.microsoft.com/en-us/edge"

if [[ ${PN} == microsoft-edge ]]; then
MY_PN=${PN}-stable
else
MY_PN=${PN}
fi

KEYWORDS="-* ~amd64"

MY_P="${MY_PN}_${PV}-1"

SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"

LICENSE="microsoft-edge"
SLOT="0"
RESTRICT="bindist mirror strip"

RDEPEND="
app-accessibility/at-spi2-atk:2
app-accessibility/at-spi2-core:2
app-misc/ca-certificates
dev-libs/atk
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
media-fonts/liberation-fonts
media-libs/alsa-lib
media-libs/mesa[gbm]
net-misc/curl[ssl]
net-print/cups
sys-apps/dbus
sys-apps/util-linux
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3[X]
x11-libs/libdrm
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libxcb
x11-libs/libxkbcommon
x11-libs/libxshmfence
x11-libs/pango
x11-misc/xdg-utils
"

QA_PREBUILT="*"
QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
S=${WORKDIR}
EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"

pkg_nofetch() {
eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
}

pkg_pretend() {
# Protect against people using autounmask overzealously
use amd64 || die "microsoft-edge only works on amd64"
}

pkg_setup() {
chromium_suid_sandbox_check_kernel_config
}

src_unpack() {
:
}

src_install() {
dodir /
cd "${ED}" || die
unpacker

rm _gpgorigin || die

rm -r etc usr/share/menu || die
mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die

gzip -d usr/share/doc/${PF}/changelog.gz || die
gzip -d usr/share/man/man1/${MY_PN}.1.gz || die

local suffix=
[[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
[[ ${PN} == microsoft-edge-dev ]] && suffix=_dev

local size
for size in 16 24 32 48 64 128 256 ; do
newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
done

pax-mark m "${EDGE_HOME}/msedge"
}

0 comments on commit 6d7bb0e

Please sign in to comment.