Skip to content

Commit

Permalink
sci-biology/rebase: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 1, 2015
1 parent e8137a3 commit 6dcb50e
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-biology/rebase/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST rebase-1508.tar.xz 69944352 SHA256 579ef686b0efea32d88633f85411da9c1396572eec0d20bd163ca7bf615c7b04 SHA512 d5dc9eb704ce28ab7951ab2a8781de76dcbd7a4b6d6c6634abcd36766c8dce77b6d8a712789fe6293a6ddc66cd9103e17121b0ff52f0d3fbabfc5bf47c2f2100 WHIRLPOOL f082a3096cef636a61a176d3d3fe5b993bc83e3b332d134ebc20201d21f2f66e3400ffc5d561018c63fb3201c5fc0862126a32c17c5c96f118859b62a618d341
DIST rebase-1509.tar.xz 81228428 SHA256 ffad3955197850b4383bf7b96278af357cb99bec129e7a00d7d601e76868870b SHA512 2d9f90c24ab977b29a1e1e790966f48274691375ab5f4b7a4f37c1e62dc8bd4d0b4409475e9b97bb63e3f481066f8407efc4d1314ee24c836f60b53d736d77ed WHIRLPOOL ab86576f037d142a285f3830f88e5b750a52f79c90f35bd117695a5de125c753747329522b1f514c503ff7e28e8aaaa2298bff3379f134db06fc270ec7364a52
DIST rebase-1510.tar.xz 90412200 SHA256 0a33a34003c95f65d8ec8bbf11907bccad47d0bdddc39030a663df5ef2922f87 SHA512 c76b42df5a5bc64a951693b35a8664195a0fb1b84bdd64f80e8986a705ca1279e51c324153a83272ecb9b3dfb3fd565cb43c2b25c9e37655767c278e6320590e WHIRLPOOL 238841844c19ad028147a4a5a366a219e405b1ae1d0ae79767775518a0ecdabe37948a260724e4053af183ad00799c60da21d57dae84cdc6859e19a04aac314a
46 changes: 46 additions & 0 deletions sci-biology/rebase/rebase-1510.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

MY_PV=${PV#1}

DESCRIPTION="A restriction enzyme database"
HOMEPAGE="http://rebase.neb.com"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"

SLOT="0"
LICENSE="public-domain"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="emboss minimal"

RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
DEPEND="${RDEPEND}"

RESTRICT="binchecks strip"

src_compile() {
if use emboss; then
echo; einfo "Indexing Rebase for usage with EMBOSS."
mkdir REBASE || die
EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
-protofile proto.${MY_PV} -equivalences \
|| die "Indexing Rebase failed."
echo
fi
}

src_install() {
if ! use minimal; then
insinto /usr/share/${PN}
doins withrefm.${MY_PV} proto.${MY_PV}
fi
newdoc REBASE.DOC README
if use emboss; then
insinto /usr/share/EMBOSS/data/REBASE
doins REBASE/embossre.{enz,ref,sup}
insinto /usr/share/EMBOSS/data
doins REBASE/embossre.equ
fi
}

0 comments on commit 6dcb50e

Please sign in to comment.