Skip to content

Commit

Permalink
dev-libs/ppl: version bump to 1.2 #601156
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Dec 8, 2016
1 parent 74e9609 commit 6ded579
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/ppl/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ppl-0.12.1.tar.bz2 14938132 SHA256 4022e54772f81c8ef66d3dd4c3d8dca48f72f9af614d8a36d05fbf5917f2b198 SHA512 e8a4c92271f608e79c5828c71ff2d36c681dd4bd48b5d31353b2a27bcf827a5cb8f0dcdfee3e13cf9f202f35a7693ddf9880dc4d5b8445ec558cef1319f43925 WHIRLPOOL 6616253d5c02c84294ec63e0601fa7bc65772fc72e6cea68f1300fa2b46f551311589813268d8e869cb59295d8fdc5be17a5b3d0cbb7b62fe0bc06a8bf9e1f39
DIST ppl-1.1.tar.xz 14734820 SHA256 c48ccd74664ec2cd3cdb5e37f287974ccb062f0384dc658d4053c424b19ad178 SHA512 ae0503fb3eac494fa3edf5d5c9ec61e2419e6e2fa57d30323f7d0360ff080b033686410c7462f5b2ff5514803451cb91e9c0fc14cf953485c5f5fd664448cc27 WHIRLPOOL d1b85fe9b44195f7fdc0573b32291a70183ce9de5e29fbb502a5d181a6e0ae11998dd5cfb52ec7ce3e1aed36433a823484488bfaf93362ac3b45a7556a2e9b6a
DIST ppl-1.2.tar.xz 14136236 SHA256 691f0d5a4fb0e206f4e132fc9132c71d6e33cdda168470d40ac3cf62340e9a60 SHA512 b509ed85fa6aedd40119bd4c980b17f33072c56c2acd923da3445b6bc80d48051cfa4c04cce96f6974711f5279c24b31cb3869f87b2eb6a2a1b30a058c809350 WHIRLPOOL cf2d5895d7d740c650707840caadd45d785411875b1c55db141928a288a1475f50d4f1e6ac829062ab021a920e9581be7822679e9cf2ea11dc64ac70cfa2e5dd
59 changes: 59 additions & 0 deletions dev-libs/ppl/ppl-1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

DESCRIPTION="The Parma Polyhedra Library provides numerical abstractions for analysis of complex systems"
HOMEPAGE="http://bugseng.com/products/ppl"
SRC_URI="http://bugseng.com/products/ppl/download/ftp/releases/${PV}/${P}.tar.xz"

LICENSE="GPL-3"
SLOT="0/4.14" # SONAMEs
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~sparc-solaris"
IUSE="+cxx doc lpsol pch static-libs test"

RDEPEND=">=dev-libs/gmp-6[cxx]
lpsol? ( sci-mathematics/glpk )
!dev-libs/cloog-ppl"
DEPEND="${RDEPEND}
app-arch/xz-utils
sys-devel/m4"

pkg_setup() {
if use test ; then
ewarn "The PPL testsuite will be run."
ewarn "Note that this can take several hours to complete on a fast machine."
fi
}

src_configure() {
local interfaces=( c )
use cxx && interfaces+=( cxx )
econf \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--disable-debugging \
--disable-optimization \
$(use_enable doc documentation) \
$(use_enable lpsol ppl_lpsol) \
$(use_enable pch) \
$(use_enable static-libs static) \
--enable-interfaces="${interfaces[*]}" \
$(use test && echo --enable-check=quick)
}

src_test() {
# default src_test runs with -j1, overriding it here saves about
# 30 minutes and is recommended by upstream
emake check
}

src_install() {
default
use static-libs || find "${ED}"/usr -name 'libppl*.la' -delete

pushd "${ED}/usr/share/doc/${PF}" >/dev/null || die
rm gpl* fdl* || die
if ! use doc ; then
rm -r *-html/ *.ps.gz *.pdf || die
fi
}

0 comments on commit 6ded579

Please sign in to comment.