Skip to content

Commit

Permalink
dev-qt/qtwebkit: fix linking against libpthread
Browse files Browse the repository at this point in the history
Gentoo-Bug: 581282

Package-Manager: portage-2.2.28
  • Loading branch information
Pesa committed May 5, 2016
1 parent a9cf6a5 commit 6df5012
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
32 changes: 32 additions & 0 deletions dev-qt/qtwebkit/files/qtwebkit-5.6.0-pthread.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From 5f359baacdf92fabcece83f0a2b30f74c7c02a3c Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen <[email protected]>
Date: Mon, 22 Feb 2016 10:57:32 +0100
Subject: [PATCH] Fix linking with libpthread

WebKit use libpthread directly but is depending on other qt modules
causing it to be linked against, which might break unless -lpthread
is last. Instead just add it explicitly after the static libraries.

Change-Id: I2b95cff2c96373f8dce6f95052c4fccbe1982b33
Reviewed-by: Simon Hausmann <[email protected]>
(cherry picked from commit 5dd4bb67cfce812fd7686e43616e2069f354a7df)
Reviewed-by: Allan Sandfeld Jensen <[email protected]>
---
Tools/qmake/mkspecs/features/default_post.prf | 1 +
1 file changed, 1 insertion(+)

diff --git a/Tools/qmake/mkspecs/features/default_post.prf b/Tools/qmake/mkspecs/features/default_post.prf
index 67276b7..39bb3f7 100644
--- a/Tools/qmake/mkspecs/features/default_post.prf
+++ b/Tools/qmake/mkspecs/features/default_post.prf
@@ -201,6 +201,7 @@ needToLink() {
linkAgainstLibrary($$library, $$eval(WEBKIT.$${library_identifier}.root_source_dir))
LIBS += $$eval(WEBKIT.$${library_identifier}.dependent_libs)
}
+ posix:!darwin: LIBS += -lpthread
}

creating_module {
--
2.8.2

1 change: 1 addition & 0 deletions dev-qt/qtwebkit/qtwebkit-5.6.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -67,6 +67,7 @@ DEPEND="${RDEPEND}

PATCHES=(
"${FILESDIR}/${PN}-5.4.2-system-leveldb.patch"
"${FILESDIR}/${PN}-5.6.0-pthread.patch" # bug 581282
)

src_prepare() {
Expand Down

0 comments on commit 6df5012

Please sign in to comment.