Skip to content

Commit

Permalink
app-doc/doxygen: version bump to 1.8.15
Browse files Browse the repository at this point in the history
Thanks to Sven Eden for patches!

Closes: https://bugs.gentoo.org/682486
Package-Manager: Portage-2.3.67, Repoman-2.3.16
Signed-off-by: Matthias Maier <[email protected]>
  • Loading branch information
tamiko committed Jun 30, 2019
1 parent cfade0c commit 6e116e8
Show file tree
Hide file tree
Showing 4 changed files with 178 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-doc/doxygen/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST doxygen-1.8.14.src.tar.gz 4877980 BLAKE2B 9886e5165188548e0c8a3760a53709615385ab175795d07156584f3878996c8c5f18e439b6e45352a32ba5cd40e9b7fdb29cdf86511e1be70b18315069e33377 SHA512 5fac7e457a51b1f8e39fb65de5e0c07633e573f74e876580e7bcad5693540d6970fde1b2cb799a4df6ab9dfca951ece15b76b3010134d7658db3500183bea85c
DIST doxygen-1.8.15.src.tar.gz 5097791 BLAKE2B 08903bf06666911df0810ea0a7b86066e7682833b03ae5660094112c5c6506f072c5818185ce8166d09328e62092461acdb4516b58fe9369119f5f6bdd64331a SHA512 a5512e78be66c1591d8ec7e284d5d25c92a97218c79e6fed3c538c723a8dfef4ff7085970bf271a6b639e907157cd4df9fb55d3c975f8d3302fb1012a4d92079
134 changes: 134 additions & 0 deletions app-doc/doxygen/doxygen-1.8.15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6} )

inherit cmake-utils eutils python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/doxygen/doxygen.git"
SRC_URI=""
else
SRC_URI="http://doxygen.nl/files/${P}.src.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="Documentation system for most programming languages"
HOMEPAGE="https://www.stack.nl/~dimitri/doxygen/"

LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"

RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
virtual/libiconv
clang? ( >=sys-devel/clang-4.0.0:= )
dot? (
media-gfx/graphviz
media-libs/freetype
)
doxysearch? ( dev-libs/xapian:= )
latex? (
dev-texlive/texlive-bibtexextra
dev-texlive/texlive-fontsextra
dev-texlive/texlive-fontutils
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
)
qt5? (
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
)
sqlite? ( dev-db/sqlite:3 )
"

REQUIRED_USE="doc? ( latex )"

DEPEND="sys-devel/flex
sys-devel/bison
doc? ( ${PYTHON_DEPS} )
${RDEPEND}"

# src_test() defaults to make -C testing but there is no such directory (bug #504448)
RESTRICT="test"

PATCHES=(
"${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
"${FILESDIR}/${PN}-1.8.15-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.8.15-llvm7.patch" #666692
"${FILESDIR}/${PN}-1.8.14-xml-c++.patch" #doxygen/doxygen#6892
)

DOCS=( LANGUAGE.HOWTO README.md )

pkg_setup() {
use doc && python-any-r1_pkg_setup
}

src_prepare() {
cmake-utils_src_prepare

# Ensure we link to -liconv
if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
local pro
for pro in */*.pro.in */*/*.pro.in; do
echo "unix:LIBS += -liconv" >> "${pro}" || die
done
fi

# Call dot with -Teps instead of -Tps for EPS generation - bug #282150
sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die

# fix pdf doc
sed -i.orig -e "s:g_kowal:g kowal:" \
doc/maintainers.txt || die

if is-flagq "-O3" ; then
ewarn
ewarn "Compiling with -O3 is known to produce incorrectly"
ewarn "optimized code which breaks doxygen."
ewarn
elog
elog "Continuing with -O2 instead ..."
elog
replace-flags "-O3" "-O2"
fi
}

src_configure() {
local mycmakeargs=(
-Duse_libclang=$(usex clang)
-Dbuild_doc=$(usex doc)
-Dbuild_search=$(usex doxysearch)
-Dbuild_wizard=$(usex qt5)
-Duse_sqlite3=$(usex sqlite)
)
use doc && mycmakeargs+=(
-DDOC_INSTALL_DIR="share/doc/${P}"
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile

if use doc; then
export VARTEXFONTS="${T}/fonts" # bug #564944

if ! use dot; then
sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
{Doxyfile,doc/Doxyfile} \
|| die "disabling dot failed"
fi
cmake-utils_src_make -C "${BUILD_DIR}" docs
fi
}

src_install() {
cmake-utils_src_install
}
32 changes: 32 additions & 0 deletions app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
--- a/addon/doxysearch/CMakeLists.txt 2019-04-03 18:43:47.995610511 +0200
+++ b/addon/doxysearch/CMakeLists.txt 2019-04-03 18:45:27.730609191 +0200
@@ -18,6 +18,7 @@
${ZLIB_LIBRARIES}
${WIN_EXTRA_LIBS}
qtools
+ pthread
)

add_executable(doxysearch.cgi
@@ -27,6 +28,7 @@
${XAPIAN_LIBRARIES}
${ZLIB_LIBRARIES}
${WIN_EXTRA_LIBS}
+ pthread
)

install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
--- a/addon/doxywizard/CMakeLists.txt 2019-04-03 18:43:59.139610364 +0200
+++ b/addon/doxywizard/CMakeLists.txt 2019-04-03 18:45:14.151609371 +0200
@@ -102,9 +102,9 @@
)

if(Qt5Core_FOUND)
- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml)
+ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml pthread)
else()
- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY})
+ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} pthread)
endif()

install(TARGETS doxywizard DESTINATION bin)
11 changes: 11 additions & 0 deletions app-doc/doxygen/files/doxygen-1.8.15-llvm7.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/src/CMakeLists.txt 2019-04-04 06:51:41.509647160 +0200
+++ b/src/CMakeLists.txt 2019-04-04 06:52:08.413646804 +0200
@@ -263,7 +263,7 @@
add_definitions(${LLVM_DEFINITIONS})
llvm_map_components_to_libnames(llvm_libs support core option)
target_compile_definitions(doxygen PRIVATE ${LLVM_DEFINITIONS})
- set(CLANG_LIBS libclang clangTooling ${llvm_libs})
+ set(CLANG_LIBS libclang clangTooling clangBasic clangLex ${llvm_libs})
endif()

target_link_libraries(doxygen

0 comments on commit 6e116e8

Please sign in to comment.