Skip to content

Commit

Permalink
app-backup/btrbk: 0.28.1 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed May 16, 2019
1 parent 8cb4b37 commit 6e16739
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/btrbk/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,4 @@ DIST btrbk-0.27.0.tar.xz 86648 BLAKE2B bebb1c56b5c08e588829697df1d00e89366582d7c
DIST btrbk-0.27.1.tar.xz 86764 BLAKE2B a46514a94e6f49f83f92bba6f545738fe6a0b274a7eb39a132a41e1f89e0e6428ee8e29164ca2ba249bf98d2c7a5f682a81bb5c113a9cd5af12e4abf98669684 SHA512 b30be9fa2459d34d33ed0c2ef1b4f2e7010d1d7f9dc6e6e3236550307b7e2f2f517a61d21bcd2aca3ed0750ef64259bb51c32ff26abcc70008db92e1a66212bd
DIST btrbk-0.27.2.tar.xz 87012 BLAKE2B 7b25ce04e088b9c3df1f5d4f41ec3e6aef7e48bebb8fcd4c4a8365bb73d26dd09afdf1814985362b28958a93df2797dd62444475024f66bd027303955a160604 SHA512 497d1dd1d2de712d4de80d0bfcdf6995590fd5308b81d7198af7cebe81c45fd53c8940265c1451eb95339636cf0e4c2a9162befb7cdd48cc8d4142b4e9ca75f1
DIST btrbk-0.28.0.tar.xz 99336 BLAKE2B 4becaac5a34029e57345baa3c8bb787032ddfdc523882f6334e7a0985a53194956342f792dd9022cb151aacbd64497b87aafee838b5811f716de4efc7eb54a10 SHA512 f4f3118daf55a80604dafec77087851860cfab8720d3f193ac4eec804ca39e60e3bb31d7feb45dd10c8b35b2844c680462a16f2ac0bdbd71731907f511bdc358
DIST btrbk-0.28.1.tar.xz 94740 BLAKE2B 75313aabab7208083e06a2d4bb607950c7d5d0e87188a9a8f8c97cba1549cc2d3bcfff14b2bc2d20898c44bcc0fe50d74db2e16b213dde852d89704704b70ece SHA512 0e24908b3162b2ab67e0482a38fb966bf33b3c3ee5b2f62259673af14e9309bc4707bd049403579240ec416efae6643a8b5da73f4763e3dc01b3893047e92581
77 changes: 77 additions & 0 deletions app-backup/btrbk/btrbk-0.28.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/digint/btrbk.git"
inherit git-r3
SRC_URI=""
KEYWORDS=""
else
SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
HOMEPAGE="https://digint.ch/btrbk/"
LICENSE="GPL-3+"
SLOT="0"
IUSE="+pv +doc"

DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"

RDEPEND="dev-lang/perl
net-misc/openssh
pv? ( sys-apps/pv )
>=sys-fs/btrfs-progs-4.12"

src_compile() {
emake clean
use doc && emake -C doc
}
src_install() {
local targets="install-bin install-etc install-share install-systemd"
use doc && targets="${targets} install-man install-doc"
emake \
DESTDIR="${D}" \
DOCDIR="/usr/share/doc/${PF}" \
SYSTEMDDIR="$(systemd_get_systemunitdir)" \
${targets}
}
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
upgrade_0_26_0_warning="1"
fi
if has_version "<${CATEGORY}/${PN}-0.27.0" ; then
upgrade_0_27_0_warning="1"
fi
}
pkg_postinst() {
if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
ewarn "If you are using raw targets, make sure to run the"
ewarn "\"raw_suffix2sidecar\" utility in each target directory."
fi
if [[ "${upgrade_0_27_0_warning}" == "1" ]]; then
ewarn 'Due to a bugfix in the scheduler [1] [2], previously preserved'
ewarn 'monthly/yearly backups could get deleted when upgrading to'
ewarn 'btrbk-0.27.0.'
ewarn ''
ewarn 'Before upgrading to btrbk-0.27.0, make sure to stop all cron jobs'
ewarn 'or systemd timers calling btrbk.'
ewarn ''
ewarn 'After upgrading, run "btrbk prune --dry-run --print-schedule" and'
ewarn 'check if any snapshots/backups would get deleted. If you want to'
ewarn 'forcibly preserve a snapshot/backup forever, rename it:'
ewarn ''
ewarn ' mv mysubvol.YYYYMMDD mysubvol.YYYYMMDD.keep_forever'
ewarn ''
ewarn 'Note that btrbk ignores subvolumes with unknown naming scheme, e.g.'
ewarn '(".keep_forever" suffix in the example above).'
ewarn ''
ewarn ' [1] https://github.com/digint/btrbk/issues/217'
ewarn ' [2] https://github.com/digint/btrbk/commit/719fb5f'
fi
}

0 comments on commit 6e16739

Please sign in to comment.