Skip to content

Commit

Permalink
dev-lua/lua_cliargs: add 3.0.2
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Aug 25, 2024
1 parent d1ff5a5 commit 6e2a80f
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/lua_cliargs/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lua_cliargs-3.0.2.tar.gz 31302 BLAKE2B 7ddfd44844f750b943de4d3f8efd90d535f99b959c89e3f29638b456e7f0d8e281489f84e92147800eab80bc0aa8520cb4456ddd7a73863e10eb6a75b55d68ad SHA512 3d9dac4723e8a41284eb28a7d1b5c400add91de055eb59645406929f5091c52bd71640b5f4914597b222b5ce7b43bbc918e4a34a69ce7bae726638bd2447abf8
DIST lua_cliargs-3.0_p2.tar.gz 30435 BLAKE2B 8edf60870e0d91593064876a225ef7fbe638425da13b458d6356eaa0636482ca904f9355fd15314d4893e6f5346a6faa30fb6078d191a29aa14e26aa5d74a4be SHA512 e7a475f1d41249b0a35f021a6ccca46078f5b689c1927a4dd4cab80b2e4d291babaab35cf7d64fad3ebf68d871fb5177f030c7a2b28d9f55fbeb4dd26021d024
37 changes: 37 additions & 0 deletions dev-lua/lua_cliargs/lua_cliargs-3.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

LUA_COMPAT=( lua5-{1..4} luajit )
MY_PV="${PV/_p/-}"

inherit lua

DESCRIPTION="A command-line argument parsing module for Lua"
HOMEPAGE="https://github.com/amireh/lua_cliargs"
SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${MY_PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="examples"
REQUIRED_USE="${LUA_REQUIRED_USE}"

RDEPEND="${LUA_DEPS}"
BDEPEND="virtual/pkgconfig"

HTML_DOCS=( "doc/." )

lua_src_install() {
insinto $(lua_get_lmod_dir)
doins -r src/.
}

src_install() {
lua_foreach_impl lua_src_install

use examples && dodoc -r examples
einstalldocs
}

0 comments on commit 6e2a80f

Please sign in to comment.