Skip to content

Commit

Permalink
x11-libs/vte: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
pacho2 committed Jan 30, 2016
1 parent 3500476 commit 6e685f6
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-libs/vte/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST vte-0.28.2.tar.xz 962340 SHA256 86cf0b81aa023fa93ed415653d51c96767f20b2d733
DIST vte-0.36.5.tar.xz 1017504 SHA256 c2c2ce9640f08b07667f1037862fe991081495446b735c0afb98f45e35b64edf SHA512 43f9211381238ca6cb7f49c8a9dd8f48f702e9968e038fa26ee69228c1fc86061d5dbfabb2c27f677280e89ae9080f20594f3c27481246e3f91dd5f3ea0354f6 WHIRLPOOL 22be408deecedfb7c674fbc49bac2852e5e1c28f25cd7998d20042f15a905158b2698f3e2a0a8fd4a78b89929e773779787dff9af9c6c5e006ee30ed6efdc59d
DIST vte-0.40.2.tar.xz 923852 SHA256 9b68fbc16b27f2d79e6271f2b0708808594ac5acf979d0fccea118608199fd2d SHA512 06d1c9a34e8e82e1bd54810d245d908ebb837538ba19fbaabe683cdf3b96b7cb1630516ddeabf18b0294922b8d98d2b9a2f5028c171fac2ad913974d94555eb2 WHIRLPOOL 2499e01c2b0d38645b61d4c0a1814d7a3196df6d300577380f1e622c06a974a4cd0d9799fff35f1b0680603aa3a0be38730991ace83df90bfb265009873c5858
DIST vte-0.42.1.tar.xz 924740 SHA256 9e00e2e9e94f4202b979c871f407a8815890bc0f4a8448a08534f76ab0fc9d34 SHA512 4cf917d3f343973dcb816a341276bfab7784a9f4dc6f8fb402193e9a9062503ac192ccc274fe92bb20a17ac182d21fd2268bf9c1ddea817f730db5612e3b21c0 WHIRLPOOL 65839ff61d227a62de51d31bc58fc0baa5b4126d3d1ff482c18b9086a59e91a46f0943512c056182aae1d9801656395989f0b2c8b0470b123d9cd2c6a611c061
DIST vte-0.42.3.tar.xz 927988 SHA256 96e98a40eae82d04c08f2ca1d2672659596e5b75626ba7d78df2412878ae62a0 SHA512 8eefe20a69cc66457bf5e55b2f141d2ba355fa8315e175dc2a2fa3ef7319f9dd91a7047cb49c105a771a9d7e060e9b0fc145bec123c508663cd0935486a7ec8e WHIRLPOOL ec557651c694869b7e8725da65e56c1f719818be61b4e304f9ae501cc88cee9fa4f01345f9a84f9bab44a55e730664cb000453606986d0c5863ab929bdef6494
77 changes: 77 additions & 0 deletions x11-libs/vte/vte-0.42.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
VALA_USE_DEPEND="vapigen"

inherit eutils gnome2 vala

DESCRIPTION="Library providing a virtual terminal emulator widget"
HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"

LICENSE="LGPL-2+"
SLOT="2.91"
IUSE="+crypt debug glade +introspection vala"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"

RDEPEND="
>=dev-libs/glib-2.40:2
>=x11-libs/gtk+-3.8:3[introspection?]
>=x11-libs/pango-1.22.0
sys-libs/ncurses:0=
sys-libs/zlib
x11-libs/libX11
x11-libs/libXft
glade? ( >=dev-util/glade-3.9:3.10 )
introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
"
DEPEND="${RDEPEND}
$(vala_depend)
>=dev-util/gtk-doc-am-1.13
>=dev-util/intltool-0.35
sys-devel/gettext
virtual/pkgconfig
crypt? ( >=net-libs/gnutls-3.2.7 )
"
RDEPEND="${RDEPEND}
!x11-libs/vte:2.90[glade]
"

src_prepare() {
vala_src_prepare
gnome2_src_prepare
}

src_configure() {
local myconf=""

if [[ ${CHOST} == *-interix* ]]; then
myconf="${myconf} --disable-Bsymbolic"

# interix stropts.h is empty...
export ac_cv_header_stropts_h=no
fi

# Python bindings are via gobject-introspection
# Ex: from gi.repository import Vte
gnome2_src_configure \
--disable-test-application \
--disable-static \
$(use_enable debug) \
$(use_enable glade glade-catalogue) \
$(use_with crypt gnutls) \
$(use_enable introspection) \
$(use_enable vala) \
${myconf}
}

src_install() {
DOCS="AUTHORS ChangeLog HACKING NEWS README"
gnome2_src_install
mv "${D}"/etc/profile.d/vte{,-${SLOT}}.sh || die
}

0 comments on commit 6e685f6

Please sign in to comment.