Skip to content

Commit

Permalink
app-admin/keepass: version bump to resolve CVE-2016-5119
Browse files Browse the repository at this point in the history
Gentoo-bug: 585140

Package-Manager: portage-2.3.0_rc1
  • Loading branch information
kensington committed Jun 11, 2016
1 parent 9da4337 commit 6e8059e
Show file tree
Hide file tree
Showing 2 changed files with 114 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/keepass/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST KeePass-2.30-Source.zip 4767753 SHA256 4a3c3c217bc05b13bf903612b89a09b67ed1
DIST KeePass-2.31-Source.zip 4714301 SHA256 555b1a30f374f7077bf15906b09ab36b40fd3fc5753673a3c0ee3f30f0ed7881 SHA512 e2e81e7d60bc58a18ea3b9a82741bdd6e5be88bcfcf447ae587f6177a8ff97e7c82c02fb0695142f8321c7b5f92aa982254629928dd0c12393d659380f46026d WHIRLPOOL b8b572bd7db7ce9bc67ae0a241c71cd30595753d06bfed85efafece2b3cce4893c5cc213ee44cabd81c6ff12fc2fc98234d845ed94d0068d8111d116ccc39333
DIST KeePass-2.32-Source.zip 4721787 SHA256 7c49b62c8de758dee7e9c2d6108c169d468b4e65f21e297649d3dd8c2b757385 SHA512 6c6345cedc505eaaec28c6e89e225bdad5d5ac169c364a7e04b06bbdef4223829662f6e12a7432a3785f73cbc6798ba578468be04ab1063eb96135346570c7c3 WHIRLPOOL 6ba1bff9df311950068e34f9044f5b9e29e6e571e1928093f7ad6dc23c8b7ad26a89371fc425df0f5b41d3781aa29c0c6ad4d8c0c0f077248e4ee7f9022dabe3
DIST KeePass-2.33-Source.zip 4738822 SHA256 5120a490289155a8b49c8e6893a2cc4b20fe859b34f815f17a017bae449f9958 SHA512 acbc226f96783f0d77d8b70b6a223de80ab7fd73bd750cedf0a52a46e60ed5e816281ec0bc168aea03a0fbb9bb2869ea410d208620bc46b30e53829f22644375 WHIRLPOOL 1bdcb19e6e15860f5423f5646f4481e4c6f43c474422c096a808bf5fb862268ddd42d22c67096fa2ebd2f41811d30592a69389561bd6619d0cf0c0da7ae74c0a
DIST KeePass-2.34-Source.zip 4744285 SHA256 e3f184e4deddd1aa5ee2b52e2373c772d3f3975e5eddb2fd729eb27b437011aa SHA512 a52fe7bb0cee60daa0428cf42cf2d6cfc5798fa52d535b10548880417bfe61458c5357ea3dfdb569571fa8aa958de05369c269e2dbb64af5cfa5c913fad521e0 WHIRLPOOL 2aeac242d5f1a342ec338cb442b8083f4dc72635d9bc8b02cd2aad4613ecf9f311cddf0832a3f1ebe03d881dce41d3a77edb097e3853967d467c2ce55b8d33cb
113 changes: 113 additions & 0 deletions app-admin/keepass/keepass-2.34.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,113 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils fdo-mime gnome2-utils mono-env multilib

MY_PN="KeePass"
DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
HOMEPAGE="http://keepass.info/"
SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="aot"

COMMON_DEPEND=">=dev-lang/mono-2.10.5"
RDEPEND="${COMMON_DEPEND}
dev-dotnet/libgdiplus[cairo]"
DEPEND="${COMMON_DEPEND}
app-arch/unzip"

S=${WORKDIR}

src_prepare() {
# Force text mode for >grep-2.21 (bug #574480)
epatch "${FILESDIR}/${PN}-2.31-force-text-grep.patch"

# Remove Windows-specific things
pushd Build > /dev/null || die
. PrepMonoDev.sh || die
popd > /dev/null || die

# KeePass looks for some XSL files in the same folder as the executable,
# we prefer to have it in /usr/share/KeePass
epatch "${FILESDIR}/${PN}-2.20-xsl-path-detection.patch"
# bug # 558094
if has_version ">=dev-lang/mono-4" ; then
sed -i -e 's! ToolsVersion="3.5"!!g' Translation/TrlUtil/TrlUtil.csproj || die
sed -i -e 's/Format Version 10.00/Format Version 11.00/' KeePass.sln || die
fi
}

src_compile() {
# Build with Release target
xbuild /target:KeePass /property:Configuration=Release || die

# Run Ahead Of Time compiler on the binary
if use aot; then
cp Ext/KeePass.exe.config Build/KeePass/Release/
mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
fi
}

src_install() {
# Wrapper script to launch mono
make_wrapper ${PN} "mono /usr/$(get_libdir)/${PN}/KeePass.exe"

# Some XSL files
insinto /usr/share/${PN}/XSL
doins Ext/XSL/*

insinto /usr/$(get_libdir)/${PN}/
exeinto /usr/$(get_libdir)/${PN}/
doins Ext/KeePass.exe.config
# Default configuration, simply says to use user-specific configuration
doins Ext/KeePass.config.xml

# The actual executable
doexe Build/KeePass/Release/KeePass.exe

# Copy the AOT compilation result
if use aot; then
doexe Build/KeePass/Release/KeePass.exe.so
fi

# Prepare the icons
newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"

# Create a desktop entry and associate it with the KeePass mime type
make_desktop_entry ${PN} ${MY_PN} ${PN} "System;Security" "MimeType=application/x-keepass2;"

# MIME descriptor for .kdbx files
insinto /usr/share/mime/packages/
doins "${FILESDIR}/${PN}.xml"
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
fdo-mime_mime_database_update
fdo-mime_desktop_database_update

if ! has_version x11-misc/xdotool ; then
elog "Optional dependencies:"
elog " x11-misc/xdotool (enables autotype)"
fi

elog "Some systems may experience issues with copy and paste operations."
elog "If you encounter this, please install x11-misc/xsel."
}

pkg_postrm() {
gnome2_icon_cache_update
fdo-mime_mime_database_update
fdo-mime_desktop_database_update
}

0 comments on commit 6e8059e

Please sign in to comment.