Skip to content

Commit

Permalink
media-libs/mediastreamer: Fix build with ffmpeg-4
Browse files Browse the repository at this point in the history
Tnanks-to: Bastien Le Querrec <[email protected]>
Closes: https://bugs.gentoo.org/655170
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Nov 29, 2018
1 parent 75367ee commit 6ea32cd
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 1 deletion.
22 changes: 22 additions & 0 deletions media-libs/mediastreamer/files/mediastreamer-2.9.0-ffmpeg4.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
diff --git a/src/videofilters/nowebcam.c b/src/videofilters/nowebcam.c
index 60e38530..52cc3359 100644
--- a/src/videofilters/nowebcam.c
+++ b/src/videofilters/nowebcam.c
@@ -32,7 +32,7 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#ifndef NO_FFMPEG
#include "ffmpeg-priv.h"
#else
-#define FF_INPUT_BUFFER_PADDING_SIZE 32
+#define AV_INPUT_BUFFER_PADDING_SIZE 32
#endif

#if TARGET_OS_IPHONE
@@ -1740,7 +1740,7 @@ mblk_t *ms_load_jpeg_as_yuv(const char *jpgpath, MSVideoSize *reqsize){
m=ms_load_generate_yuv(reqsize);
return m;
}
- jpgbuf=(uint8_t*)ms_malloc0(statbuf.st_size + FF_INPUT_BUFFER_PADDING_SIZE);
+ jpgbuf=(uint8_t*)ms_malloc0(statbuf.st_size + AV_INPUT_BUFFER_PADDING_SIZE);
if (jpgbuf==NULL)
{
close(fd);
3 changes: 2 additions & 1 deletion media-libs/mediastreamer/mediastreamer-2.9.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -83,6 +83,7 @@ PATCHES=(
"${FILESDIR}/${P}-tests.patch"
"${FILESDIR}/${P}-xxd.patch"
"${FILESDIR}/${P}-ffmpeg3.patch"
"${FILESDIR}/${P}-ffmpeg4.patch"
)

src_prepare() {
Expand Down

0 comments on commit 6ea32cd

Please sign in to comment.