forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-analyzer/prometheus-node_exporter: Version bump to 0.15.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
- Loading branch information
Showing
3 changed files
with
68 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST prometheus-node_exporter-0.14.0.tar.gz 1086402 SHA256 312d7e1c07d6a7548f2f116b983da87f7b3a7630f9332eb41c306fd71b2e6ec1 SHA512 28b1c3a17b0065f7005636f0751e535f9455675f7c17546a584fb709f43f2608e4854fe4e7f0e3790b89eff21016b41dccb0a96f16eae466de1040b57c4b1c98 WHIRLPOOL 176eb95a76fefb388817fa27f0b43fca9b1ed235d39e73e97254ef829025d7493f710ce0ef2cf11b00ffa509c08f7b12664cdff38939a5ea62eb79e7991c0bd3 | ||
DIST prometheus-node_exporter-0.15.0.tar.gz 1324698 SHA256 87a057081e2034f85e997f9e1343aaf45e1b6ad9fa51411caf97a03fe1c46ccb SHA512 0630c112742ef029d24a0086f9cf0a2efcf1125987dc1e6978055d3e74b820bbd91fd2e7391aa5108881a08a2ec06aff4c1500ebbb6644b46fd7e6271f2b8fa9 WHIRLPOOL 8d4da98c4df9dd344ea68e64deb550197af04b01251dfc784c992007b24677843af8f5d973fafef6e679ce1b2a769512a43419406252cf5f9d35b91c17011a1f |
19 changes: 19 additions & 0 deletions
19
net-analyzer/prometheus-node_exporter/files/prometheus-node_exporter-1.initd
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
#!/sbin/openrc-run | ||
# Copyright 2016-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
description="Prometheus machine metrics exporter" | ||
pidfile=${pidfile:-"/run/${RC_SVCNAME}.pid"} | ||
user=${user:-${RC_SVCNAME}} | ||
group=${group:-${RC_SVCNAME}} | ||
|
||
command="/usr/bin/node_exporter" | ||
command_args="${command_args:---collector.textfile.directory=/var/lib/node_exporter/}" | ||
command_background="true" | ||
start_stop_daemon_args="--user ${user} --group ${group} \ | ||
--stdout /var/log/node_exporter/${RC_SVCNAME}.log \ | ||
--stderr /var/log/node_exporter/${RC_SVCNAME}.log" | ||
|
||
depend() { | ||
after net | ||
} |
48 changes: 48 additions & 0 deletions
48
net-analyzer/prometheus-node_exporter/prometheus-node_exporter-0.15.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit user golang-build golang-vcs-snapshot | ||
|
||
EGO_PN="github.com/prometheus/node_exporter" | ||
EGIT_COMMIT="v${PV/_rc/-rc.}" | ||
NODE_EXPORTER_COMMIT="6e2053c" | ||
ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64" | ||
|
||
DESCRIPTION="Prometheus exporter for machine metrics" | ||
HOMEPAGE="https://github.com/prometheus/node_exporter" | ||
SRC_URI="${ARCHIVE_URI}" | ||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
DEPEND="dev-util/promu" | ||
|
||
pkg_setup() { | ||
enewgroup ${PN} | ||
enewuser ${PN} -1 -1 -1 ${PN} | ||
} | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e "s/{{.Revision}}/${NODE_EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die | ||
} | ||
|
||
src_compile() { | ||
pushd src/${EGO_PN} || die | ||
mkdir -p bin || die | ||
GOPATH="${S}" promu build -v --prefix node_exporter || die | ||
popd || die | ||
} | ||
|
||
src_install() { | ||
pushd src/${EGO_PN} || die | ||
dobin node_exporter/node_exporter | ||
dodoc {README,CHANGELOG,CONTRIBUTING}.md | ||
popd || die | ||
keepdir /var/lib/node_exporter /var/log/node_exporter | ||
fowners ${PN}:${PN} /var/lib/node_exporter /var/log/node_exporter | ||
newinitd "${FILESDIR}"/${PN}-1.initd ${PN} | ||
newconfd "${FILESDIR}"/${PN}.confd ${PN} | ||
} |