Skip to content

Commit

Permalink
dev-util/bear: add 3.0.12
Browse files Browse the repository at this point in the history
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
gyakovlev committed Jun 4, 2021
1 parent b3064f0 commit 6f6da34
Show file tree
Hide file tree
Showing 2 changed files with 87 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/bear/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST bear-2.4.4.tar.gz 50347 BLAKE2B 73fa332cf97413e55c588f8830806a26c6905299af902c6cf1f39fd576c6261690239c1b502b28b5a2aa24e5ca521c3f1dd58aacd60e00ece4fe1840f5656155 SHA512 4ee3fd5c846149029fe9e4104e2a0d0e318a15215aa80fc5dc376e22ebea510384b02d4d62765495343cab537bacd2b1b0130c00246e081feb4e543761a594e5
DIST bear-3.0.11.tar.gz 118678 BLAKE2B 209d904a84363a87e566798dcd65ffed96cdbf3d2e753af8dc2706adb995d2999bc112eabb88db28791cbb245c373eb330cf9c20d3d886bb2caeb5c01150e65d SHA512 6d362aede911a8ad35be30638a698579582ca5de770a7c3199bb205046f08f355387099261b8d857188d526ab62024f78e3d06a225734c5f9acca03e5dfea1ec
DIST bear-3.0.12.tar.gz 118937 BLAKE2B 4ed41693a92583091b8510dd1ade55a3e5c897825205e59d9e9810aa63e5f17c5049b3b3de509665143083d44aeb6d85c63d944041bb36c6b1d842d0308d88f0 SHA512 e45e842793e9f5f2cd6b13a9795c2b6753c2fffd516e4af9f0362644c9d0952a2b0e505a4a9d53e9a1a4aa063d7368c6466367a78fececb70582ec7c4e8d7f10
86 changes: 86 additions & 0 deletions dev-util/bear/bear-3.0.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )

inherit cmake python-any-r1

DESCRIPTION="Build EAR generates a compilation database for clang tooling"
HOMEPAGE="https://github.com/rizsotto/Bear"
SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="test"

RDEPEND="
>=dev-cpp/nlohmann_json-3.7:=
>=dev-db/sqlite-3.14:=
>=dev-libs/libfmt-6.2
>=dev-libs/spdlog-1.5
>=net-libs/grpc-1.26:=
"

DEPEND="${RDEPEND}
test? (
>=dev-cpp/gtest-1.10
)
"

BDEPEND="test? (
$(python_gen_any_dep '
dev-python/lit[${PYTHON_USEDEP}]
')
)"

RESTRICT="!test? ( test )"

S="${WORKDIR}/${P^}"

pkg_setup() {
use test && python-any-r1_pkg_setup
}

src_prepare() {
cmake_src_prepare
# Turn off testing before installation
sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
}

src_configure() {
local mycmakeargs=(
-DENABLE_UNIT_TESTS="$(usex test ON OFF)"
-DENABLE_FUNC_TESTS="$(usex test ON OFF)"
)
cmake_src_configure
}

src_test() {
if has sandbox ${FEATURES}; then
ewarn "\'FEATURES=sandbox\' detected"
ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
ewarn "Skipping tests"
elif
has usersandbox ${FEATURES}; then
ewarn "\'FEATURES=usersandbox\' detected"
ewarn "Skipping tests"
elif
has network-sandbox ${FEATURES}; then
ewarn "\'FEATURES=network-sandbox\' detected"
ewarn "Skipping tests"
elif
has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
ewarn "and will fail without generic cc symlink"
ewarn "Skipping tests"
else
einfo "test may use optional tools if found: qmake gfortran valgrind"
# unit tests
cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
# functional tests
cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
fi
}

0 comments on commit 6f6da34

Please sign in to comment.