Skip to content

Commit

Permalink
media-libs/dav1d: add 1.2.1
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jun 2, 2023
1 parent c17e0f8 commit 6f711c6
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/dav1d/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST dav1d-0.9.2.tar.bz2 833722 BLAKE2B b05edd1ca627906e57923be08f1ecd73469f9a8e
DIST dav1d-1.0.0.tar.bz2 960470 BLAKE2B 79355eeceea37df81e30be49dfea3dee9747fbbb82c0a08be3bbda525881112a8eb847afe3c3ccd0447fd6ee67ae540c5120ea00d4f891ac422850c611850c97 SHA512 86c6481e787fb6b8c28521e1efb1876d1be99f5fa5332cddab1111059b44775e05203cfc5c80a1b404ee00f35a1f5e1099e21b1f0851d77fb0101567e8b1a892
DIST dav1d-1.1.0.tar.bz2 994368 BLAKE2B 877fd315fb00cb37c80f128c871641b8dbc4a7c9edb3d81afe00e65cb907ed88bcc10e2f92855d1eef51e196a7ae6d189db16dcf0e151f7ca9db715451bd28f5 SHA512 2eb177b415d1ac7bd08d54b16375afedec61f0771a5181fa93e5e6215856fc26504a7cb47de08abbea5bf18fac5ff91ca31044e7054681c380e0ab152e53aabc
DIST dav1d-1.2.0.tar.xz 866120 BLAKE2B f9c9ca8c48ba2cae8e2137bb46e9db9a2070b3fba35ca142fde836f20be8a0db11b3b0dc3f78d06780d5cf6d014b0a6b545368371f421864d3f30a35ca6fe5ef SHA512 1f1775bdcdbc38a0bb12d7f14f01ee321cc03f15d8b7c6fabe2ada3a3c46885b0eff5851ea912079a1519ef01278c3a192e3b0347b0ab9b25cafab4124f1ae6a
DIST dav1d-1.2.1.tar.xz 873008 BLAKE2B 52478112f1f2c39a020556a8ed18c1267de93fc129941eb87b75fa872188a0389389ba9c7f7ae641726ca78a0a515ce5923968374b8122fec159f33c1f65e7bc SHA512 f172eebc0a5f6c51d31fc9e9758c2dd0de51d8a5d0e00c93a5f2b1b16b7b4a37b365f9c56dea95d400e66b63af5fa4c63d9e720719ac38852777fc8c6066e4a7
61 changes: 61 additions & 0 deletions media-libs/dav1d/dav1d-1.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
inherit git-r3
else
SRC_URI="https://downloads.videolan.org/pub/videolan/dav1d/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi

inherit meson-multilib

DESCRIPTION="dav1d is an AV1 Decoder :)"
HOMEPAGE="https://code.videolan.org/videolan/dav1d"

LICENSE="BSD-2"
# Check SONAME on version bumps!
SLOT="0/6"
IUSE="+8bit +10bit +asm test xxhash"
RESTRICT="!test? ( test )"

ASM_DEPEND=">=dev-lang/nasm-2.15.05"
DEPEND="xxhash? ( dev-libs/xxhash )"
BDEPEND="
asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
)
"

DOCS=( README.md doc/PATENTS THANKS.md )

multilib_src_configure() {
local -a bits=()
use 8bit && bits+=( 8 )
use 10bit && bits+=( 16 )

local enable_asm
if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
enable_asm=false
else
enable_asm=$(usex asm true false)
fi

local emesonargs=(
-Dbitdepths=$(IFS=,; echo "${bits[*]}")
-Denable_asm=${enable_asm}
$(meson_use test enable_tests)
$(meson_feature xxhash xxhash_muxer)
)
meson_src_configure
}

multilib_src_test() {
if multilib_is_native_abi ; then
meson_src_test
fi
}

0 comments on commit 6f711c6

Please sign in to comment.