Skip to content

Commit

Permalink
dev-ml/ppx_import: bump to 1.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
aballier committed Apr 27, 2017
1 parent 5253bd5 commit 6f71e64
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/ppx_import/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ppx_import-1.1.tar.gz 12951 SHA256 083f06119fa836939bec273340828c6f2c103cd88bdf775584d2036b8f4d0f5f SHA512 24a1db1f216518fb1302f8de2984bab5ffd33cbabe311d449e3767a96a63b386d11cdfd8f783d48169523a0535754b044841821aa24533d1d1127eb4a8aa42d6 WHIRLPOOL 479223751d0e180e4df3e4e7e36b774ded8284bcf8f67054518dabc6e3c16aae538a964ea4a01528caf78b388f1cd48e3dd487bb141bd0a315c622cd531fb637
DIST ppx_import-1.2.tar.gz 13244 SHA256 f102bcefe72b8a1007ce9854baefac0c20930fe9db71fc81213e13e35016dfe2 SHA512 384a8f955573c66962383f0e3609e4764cb0056e7d5b7e5811fd9fd17e17ac58baea330131b8eb688cd4202d6e6bd5829fba024524f027201244ff10c86e0f01 WHIRLPOOL 53665ec4ab8109bc762c094535d2082befd887af28cd836bcc4f19e41d924d83e140ef4d660166d7d3198042213bed0275e72c1c58650c58039aa5abd25441d2
47 changes: 47 additions & 0 deletions dev-ml/ppx_import/ppx_import-1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

DESCRIPTION="A syntax extension for importing declarations from interface files"
HOMEPAGE="https://github.com/whitequark/ppx_import"
SRC_URI="https://github.com/whitequark/ppx_import/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="+ocamlopt test"

DEPEND="
dev-lang/ocaml:=[ocamlopt?]
dev-ml/ppx_tools:=
dev-ml/cppo:=
"
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
test? ( dev-ml/ounit dev-ml/ppx_deriving )
dev-ml/opam
dev-ml/ocamlbuild
dev-ml/findlib
"

src_compile() {
cp pkg/META.in pkg/META
ocaml pkg/build.ml \
native=$(usex ocamlopt true false) \
native-dynlink=$(usex ocamlopt true false) \
|| die
}

src_test() {
ocamlbuild -classic-display -use-ocamlfind src_test/test_ppx_import.byte -- || die
}

src_install() {
opam-installer -i \
--prefix="${ED}/usr" \
--libdir="${D}/$(ocamlc -where)" \
--docdir="${T}/dontinstallit" \
${PN}.install || die
dodoc CHANGELOG.md README.md
}

0 comments on commit 6f71e64

Please sign in to comment.