Skip to content

Commit

Permalink
dev-lang/swi-prolog: bump 7.3 development version
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
keriharris committed Jul 17, 2016
1 parent e843d78 commit 7013b9d
Show file tree
Hide file tree
Showing 2 changed files with 144 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/swi-prolog/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST swipl-7.2.3.tar.gz 16192142 SHA256 43657d51b7c5887bc2d2bced50a9822b86a08a68
DIST swipl-7.3.19.tar.gz 16285473 SHA256 693cfeac8f31d050ddcec27e550586359e98a64dc820398997d0ce6b8f564354 SHA512 19fd78903b1df3ddb76c48930571fc53c68e4e3913b1fd15c38d89f6443274910f02c8585585addf274aba6be5061a1c62e7f8af9bb4bcdacd511b3efe5888ab WHIRLPOOL 832acffbf502afd084f467c7cc0eea293070b123b97983d1926829ecd08bb44a62c884b2c24602c744380d9de24bd94d1d7de8780b38e29aef91fc03018ae1ea
DIST swipl-7.3.20.tar.gz 16298706 SHA256 8dd5a73ce454e68b45a11f0aebb64bbe668a06e35198c2c12d176af9c1c19d69 SHA512 e4641c25db990603b38888fe0fef03edd0367b2293303f2e055b92e45fd46b2dd1f3fd8aad4c26ca76e6fab67c6a0826b155a0e61bbc43a6f1072b14f4470c02 WHIRLPOOL 8def423b40a5371b69cef382ff71f3089e895f8e3bc5fdbf3379a49b2596c4e5f98fe0b76b4b6c0d8ed33d9f50bf1e505b83839e2a7aa14fbe5f35c167df031e
DIST swipl-7.3.21.tar.gz 16369519 SHA256 a439fada1f5f2291ec51d500abedd10f0e0112e295fea2cffd6dd8f2ae274859 SHA512 2bb038c455e75d654aabdd3ee7c72fbe3cafd0755829c91b22cd6b2ea1d8e3be0deff038538bf39e2e9dc31d88a00c4be30444643580082ae76bbb2042b380a8 WHIRLPOOL fbc1b8ec3a15cb27c0b142a790af0bc0323d842cebc6c618641f563997befa32900940d7273b11cf00a7788bdc525077e267d8aa58d0d4d4a04e2c337282b8b4
DIST swipl-7.3.22.tar.gz 16377750 SHA256 d8047dfef86f505193190b1bc170183e43eb394d807f673b4d7aae483a47ca04 SHA512 51ef8d73c175534ed94b33488c640c229a09a015fc007ed4ee9f719e66a1f6e1dadf00e088fc5384a2249167a295a74372fe89c073337b7e51dd4640581279ba WHIRLPOOL 29be19b3405553073403ffda45bb21eb1500433ccc8ea889d174e06fd6265a85bcfce839c1de85d12ecb634cd4885bfe7f5d674658f6c0bce07d60a15afdff68
143 changes: 143 additions & 0 deletions dev-lang/swi-prolog/swi-prolog-7.3.22.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,143 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils flag-o-matic java-pkg-opt-2 multilib

PATCHSET_VER="0"

DESCRIPTION="free, small, and standard compliant Prolog compiler"
HOMEPAGE="http://www.swi-prolog.org/"
SRC_URI="http://www.swi-prolog.org/download/devel/src/swipl-${PV}.tar.gz"

LICENSE="BSD-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="archive berkdb debug doc +gmp hardened java libressl minimal odbc +readline ssl static-libs test uuid zlib X"

RDEPEND="sys-libs/ncurses:=
archive? ( app-arch/libarchive )
berkdb? ( >=sys-libs/db-4:= )
zlib? ( sys-libs/zlib )
odbc? ( dev-db/unixODBC )
readline? ( sys-libs/readline:= )
gmp? ( dev-libs/gmp:0 )
ssl? (
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
)
java? ( >=virtual/jdk-1.5:= )
uuid? ( dev-libs/ossp-uuid )
X? (
virtual/jpeg:0
x11-libs/libX11
x11-libs/libXft
x11-libs/libXpm
x11-libs/libXt
x11-libs/libICE
x11-libs/libSM )"

DEPEND="${RDEPEND}
X? ( x11-proto/xproto )
java? ( test? ( =dev-java/junit-3.8* ) )"

S="${WORKDIR}/swipl-${PV}"

src_prepare() {
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
if [[ -d "${WORKDIR}"/${PV} ]] ; then
epatch "${WORKDIR}"/${PV}
fi

if ! use uuid; then
mv packages/clib/uuid.pl packages/clib/uuid.pl.unused || die
fi

# OSX/Intel ld doesn't like an archive without table of contents
sed -i -e 's/-cru/-scru/' packages/nlp/libstemmer_c/Makefile.pl || die
}

src_configure() {
append-flags -fno-strict-aliasing
use ppc && append-flags -mno-altivec
use hardened && append-flags -fno-unit-at-a-time
use debug && append-flags -DO_DEBUG

# ARCH is used in the configure script to figure out host and target
# specific stuff
export ARCH=${CHOST}

export CC_FOR_BUILD=$(tc-getBUILD_CC)

cd "${S}"/src || die
econf \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
$(use_enable gmp) \
$(use_enable readline) \
$(use_enable static-libs static) \
--enable-shared \
--enable-custom-flags COFLAGS="${CFLAGS}"

if ! use minimal ; then
local jpltestconf
if use java && use test ; then
jpltestconf="--with-junit=$(java-config --classpath junit)"
fi

cd "${S}/packages" || die
econf \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
$(use_with archive) \
$(use_with berkdb bdb ) \
$(use_with java jpl) \
${jpltestconf} \
$(use_with odbc) \
$(use_with ssl) \
$(use_with X xpce) \
$(use_with zlib) \
COFLAGS='"${CFLAGS}"'
fi
}

src_compile() {
cd "${S}"/src || die
emake

if ! use minimal ; then
cd "${S}/packages" || die
emake
./report-failed || die "Cannot report failed packages"
fi
}

src_test() {
cd "${S}/src" || die
emake check

if ! use minimal ; then
unset DISPLAY
cd "${S}/packages" || die
emake \
USE_PUBLIC_NETWORK_TESTS=false \
USE_ODBC_TESTS=false \
check
./report-failed || die
fi
}

src_install() {
emake -C src DESTDIR="${D}" install

if ! use minimal ; then
emake -C packages DESTDIR="${D}" install
if use doc ; then
emake -C packages DESTDIR="${D}" html-install
fi
./packages/report-failed || die "Cannot report failed packages"
fi

dodoc ReleaseNotes/relnotes-5.10 INSTALL README VERSION
}

0 comments on commit 7013b9d

Please sign in to comment.