Skip to content

Commit

Permalink
dev-games/recastnavigation: new package
Browse files Browse the repository at this point in the history
This was bundled with games-engines/openmw-0.46.0, unbundling it

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexey Sokolov <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
DarthGandalf authored and juippis committed Jul 8, 2020
1 parent 74f6181 commit 70236cb
Show file tree
Hide file tree
Showing 4 changed files with 165 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-games/recastnavigation/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST recastnavigation-1.5.1_p20200511.tar.gz 1541540 BLAKE2B 3878294247e26421c33019c05a8d70f9ae04ce046d1e503b2df8297e5c390c592e0222c445c9a7798c2e3eb7090b6c32d18b94015dce0a248ab17198d3054dda SHA512 bc48d9195c1ce4422359d850ad422e53c2599ff575b8c7a0ce6b7dc42720d7edd99781a1efa7bee49a00cd4ce6734f34ce9d434421471cb0cbf8e5207bbebebc
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
https://github.com/recastnavigation/recastnavigation/pull/437

diff --git a/CMakeLists.txt b/CMakeLists.txt
index d23859d..54a38d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,8 @@ option(RECASTNAVIGATION_TESTS "Build tests" ON)
option(RECASTNAVIGATION_EXAMPLES "Build examples" ON)
option(RECASTNAVIGATION_STATIC "Build static libraries" ON)

+include(GNUInstallDirs)
+
add_subdirectory(DebugUtils)
add_subdirectory(Detour)
add_subdirectory(DetourCrowd)
diff --git a/DebugUtils/CMakeLists.txt b/DebugUtils/CMakeLists.txt
index 8b6a3fc..86cfe76 100644
--- a/DebugUtils/CMakeLists.txt
+++ b/DebugUtils/CMakeLists.txt
@@ -26,10 +26,10 @@ set_target_properties(DebugUtils PROPERTIES
)

install(TARGETS DebugUtils
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT library
)

file(GLOB INCLUDES Include/*.h)
-install(FILES ${INCLUDES} DESTINATION include)
+install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
diff --git a/Detour/CMakeLists.txt b/Detour/CMakeLists.txt
index de88111..b4c457a 100644
--- a/Detour/CMakeLists.txt
+++ b/Detour/CMakeLists.txt
@@ -20,10 +20,10 @@ set_target_properties(Detour PROPERTIES
)

install(TARGETS Detour
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT library
)

file(GLOB INCLUDES Include/*.h)
-install(FILES ${INCLUDES} DESTINATION include)
+install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
diff --git a/DetourCrowd/CMakeLists.txt b/DetourCrowd/CMakeLists.txt
index 73cdf7c..7d1ace3 100644
--- a/DetourCrowd/CMakeLists.txt
+++ b/DetourCrowd/CMakeLists.txt
@@ -24,10 +24,10 @@ set_target_properties(DetourCrowd PROPERTIES
)

install(TARGETS DetourCrowd
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT library
)

file(GLOB INCLUDES Include/*.h)
-install(FILES ${INCLUDES} DESTINATION include)
+install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
diff --git a/DetourTileCache/CMakeLists.txt b/DetourTileCache/CMakeLists.txt
index 121b8ed..141a680 100644
--- a/DetourTileCache/CMakeLists.txt
+++ b/DetourTileCache/CMakeLists.txt
@@ -25,10 +25,10 @@ set_target_properties(DetourTileCache PROPERTIES


install(TARGETS DetourTileCache
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT library
)

file(GLOB INCLUDES Include/*.h)
-install(FILES ${INCLUDES} DESTINATION include)
+install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
diff --git a/Recast/CMakeLists.txt b/Recast/CMakeLists.txt
index 5e84376..3b04742 100644
--- a/Recast/CMakeLists.txt
+++ b/Recast/CMakeLists.txt
@@ -20,10 +20,10 @@ set_target_properties(Recast PROPERTIES
)

install(TARGETS Recast
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT library
)

file(GLOB INCLUDES Include/*.h)
-install(FILES ${INCLUDES} DESTINATION include)
+install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 7c17469..a98ccbf 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -8,5 +8,3 @@ add_executable(Tests ${TESTS_SOURCES})
add_dependencies(Tests Recast Detour)
target_link_libraries(Tests Recast Detour)
add_test(Tests Tests)
-
-install(TARGETS Tests RUNTIME DESTINATION bin)
16 changes: 16 additions & 0 deletions dev-games/recastnavigation/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Alexey Sokolov</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Games Project</name>
</maintainer>
</pkgmetadata>
33 changes: 33 additions & 0 deletions dev-games/recastnavigation/recastnavigation-1.5.1_p20200511.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

DESCRIPTION="Navigation mesh construction toolset for games"
HOMEPAGE="https://github.com/recastnavigation/recastnavigation"
MY_COMMIT="df27e4eb1a4ade9912f8b7d75c25769a3193dbd0"
SRC_URI="https://github.com/recastnavigation/recastnavigation/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${MY_COMMIT}"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

PATCHES=(
"${FILESDIR}/recastnavigation-1.5.1_p20200511-install.patch"
)

src_configure() {
local mycmakeargs=(
-DRECASTNAVIGATION_DEMO=OFF
-DRECASTNAVIGATION_EXAMPLES=OFF
-DRECASTNAVIGATION_STATIC=OFF
-DRECASTNAVIGATION_TESTS=$(usex test)
)

cmake_src_configure
}

0 comments on commit 70236cb

Please sign in to comment.