Skip to content

Commit

Permalink
dev-cpp/robin-hood-hashing: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Nick Sarnie <[email protected]>
  • Loading branch information
sarnex committed Feb 20, 2022
1 parent 9008614 commit 70406c7
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/robin-hood-hashing/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST robin-hood-hashing-3.11.2.tar.gz 170488 BLAKE2B 5fb688f5e21f989456e139b64447393816593ad2a1c3537d067d8ea1717aceaa879e27616657354f62e1466ca491f9d302448a73cddb53c7156a623eb375016b SHA512 5d55f054e29ae34d410eb0103f9f0aa1faf47e313b9f089c73b9c26fd9bedf132f6bb13b4bcd2664309c32fe7e859e346d0a6e7ab7f46b294f9b8db207577795
DIST robin-hood-hashing-3.11.5.tar.gz 177134 BLAKE2B b114c1d68ff2eae4cdb526e67def750a11056c2b5c400eab0870fda7c81dde5cf3bb168ea13ed3d34f2e57edffea5c58cb79ffb5328ecf839c723c71f54676d3 SHA512 5f73e089b1e8ec41a9bedded22bc64a789d3a3d04873a2ad9f8cc2970797a473b0f4d3436c2324b3ced85a0d983998a75b1dfaf2b7f3b77235b29806ff2fd489
23 changes: 23 additions & 0 deletions dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
HOMEPAGE="https://github.com/martinus/robin-hood-hashing"

LICENSE="MIT"
SLOT="0"

src_configure() {
local mycmakeargs=(
-DRH_STANDALONE_PROJECT=OFF
-DCMAKE_INSTALL_LIBDIR="${ESYSROOT}/usr/share/"
)
cmake_src_configure
}

0 comments on commit 70406c7

Please sign in to comment.