Skip to content

Commit

Permalink
app-text/yodl: bump to 4.03.00
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jan 7, 2021
1 parent df13bd5 commit 704a1ad
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/yodl/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST yodl-4.02.01.tar.gz 308670 BLAKE2B f94c094f17ec99e66f64a704e41814274f61128ff21b11077d772874dcbc9f15fbc878df8831e7f73d9b6c89a497462c694bc0bdb6cd5637c0db08303e3838d5 SHA512 59e23bb173786b8806f56bf302dee9d8d971d0d840c609e2b24d9783b5866fca2509be844616318f9a4f302117b3a41f620be5cba09181e7ccdcf0c141402be7
DIST yodl-4.02.02.tar.gz 309075 BLAKE2B ce9da287ca59e20319ae8a132553b669ffff926c79e7ffbf7891af3e777c45815cbd784eaf8d706b7f4b8240ceac41c38882c7b5d2b51e2691da249b0f5be43b SHA512 531b5b61f85ed556163b0cf76a30451212849e5e03e11819cc466603db0856737a9d3bc34ba11419befd7925ec1bac33f92b707c38acd2fa8047e3e1223d0a78
DIST yodl-4.03.00.tar.gz 309212 BLAKE2B 9a89dfda5f4138f466bc2f871724087ff2c0084d06d81c32e1e865744e1c133b1073becac30e817f2f997c351b8f8192e942616174acb644dcab40d5d64c9d36 SHA512 ec5edaf932d94e9272a08867322e8fbfec65f612447fa412a7c19412569a6d811bbe5badd0af692837086a9ee8cdf8bb8f0c10a3e8333ef6096513b263c8d831
72 changes: 72 additions & 0 deletions app-text/yodl/yodl-4.03.00.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs flag-o-matic

DESCRIPTION="Your Own Document Language: a pre-document language and tools to process it"
HOMEPAGE="https://fbb-git.gitlab.io/yodl/ https://gitlab.com/fbb-git/yodl"
SRC_URI="https://gitlab.com/fbb-git/${PN}/-/archive/${PV}/${P}.tar.gz"
S="${WORKDIR}/${P}/${PN}"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

BDEPEND="
>=dev-util/icmake-8.00.00
doc? (
dev-texlive/texlive-latexextra
dev-texlive/texlive-plaingeneric
)
"

pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if tc-is-gcc && [[ $(gcc-major-version) -lt 8 ]]; then
die "Your compiler doesn't fully support C++17. Use GCC 8 or newer."
elif tc-is-clang && [[ $(clang-major-version) -lt 6 ]]; then
die "Your compiler doesn't fully support C++17. Use Clang 6 or newer."
fi
fi
}

src_prepare() {
sed -e "/DOC.* =/s/yodl\(-doc\)\?/${PF}/" \
-e "/COMPILER =/s/gcc/$(tc-getCC)/" \
-e "/CXX =/s/g++/$(tc-getCXX)/" \
-i INSTALL.im || die

sed -e "s/g++/$(tc-getCXX)/" \
-e "s:#define CLS://\0:" \
-i verbinsert/icmconf || die

sed -e "s/ar r /$(tc-getAR) r /" \
-e "s/ranlib/$(tc-getRANLIB)/" \
-i icmake/stdcompile || die

sed -e '/strip/s|"-s"|""|g' \
-i icmake/program || die

# required for std::filesystem usage
append-cxxflags -std=c++17

default
}

src_compile() {
local target
for target in programs macros man $(usex doc manual ''); do
./build ${target} || die "${target} failed"
done
}

src_install() {
./build install programs "${ED}" || die
./build install macros "${ED}" || die
./build install man "${ED}" || die
./build install docs "${ED}" || die
use doc && { ./build install manual "${ED}" || die ; }
}

0 comments on commit 704a1ad

Please sign in to comment.