Skip to content

Commit

Permalink
mate-base/caja: Bump to 1.24.1
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/778857
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Adam Feldman <[email protected]>
  • Loading branch information
NP-Hardass committed Jun 30, 2021
1 parent 7f5fffc commit 707ee9d
Show file tree
Hide file tree
Showing 2 changed files with 96 additions and 0 deletions.
2 changes: 2 additions & 0 deletions mate-base/caja/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
DIST caja-1.24.0.tar.xz 5221716 BLAKE2B 66d628ac0f50e2c388935420e29dfe15a8f5f127fd7b39e92ebbd67b6c929cda1a2dec1f510fb89890602adaef6a741f0ee3e15d27ab9741c5223c7966b3b908 SHA512 a68b23876cfa1171d5b1c75e4998c6b15f0ceebdc4fcaabb8d362e32e35b915b1a91a38648532ac8acc162dac50aeb4d07eff417ce2db7a8c50d68bd38a0b548
DIST caja-1.24.1.tar.xz 5308268 BLAKE2B 82d2ff39152bd6d961d233d3712237b8192cf680d419f44cb8a2857228f4648d7667213740a1b2fdf024ac5958586f9b0b8f99e3770710a5ec5c6651a85dadf1 SHA512 34ba1e384e3de4ee3e6dddafa4ef4ccd5f626352cf5b42d6178e96395762653478cbdabb109cd0f2418ed463fd4743ef8a34be0a6b4294ad5355fea6dbfd53cc
94 changes: 94 additions & 0 deletions mate-base/caja/caja-1.24.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MATE_LA_PUNT="yes"

inherit mate virtualx

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

DESCRIPTION="Caja file manager for the MATE desktop"
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"

IUSE="+introspection +mate packagekit xmp"

COMMON_DEPEND="
dev-libs/atk
>=dev-libs/glib-2.58.1:2
>=dev-libs/libxml2-2.4.7:2
gnome-base/dconf
>=gnome-base/gvfs-1.10.1:0[udisks]
>=mate-base/mate-desktop-1.17.3:0
>=media-libs/libexif-0.6.14:0
x11-libs/cairo
>=x11-libs/gdk-pixbuf-2.36.5:2
>=x11-libs/gtk+-3.22:3[introspection?]
>=x11-libs/libnotify-0.7.0:0
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libXext
x11-libs/libXft
x11-libs/libXrender
>=x11-libs/pango-1.1.2
introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
packagekit? ( app-admin/packagekit-base )
xmp? ( >=media-libs/exempi-1.99.5:2 )
"

RDEPEND="${COMMON_DEPEND}
virtual/libintl
!!mate-base/mate-file-manager
"

DEPEND="${COMMON_DEPEND}
>=dev-lang/perl-5:=
dev-util/gdbus-codegen
dev-util/glib-utils
dev-util/gtk-doc
dev-util/gtk-doc-am
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"

PDEPEND="mate? ( >=x11-themes/mate-icon-theme-${MATE_BRANCH} )"

# TODO: Test fails because Caja is not merged yet:
# GLib-GIO-ERROR **: Settings schema 'org.mate.caja.preferences' is not installed
RESTRICT="test"

src_prepare() {
# Remove unnecessary CFLAGS.
sed -i -e 's:-DG.*DISABLE_DEPRECATED::g' \
configure.ac eel/Makefile.am || die

mate_src_prepare
}

src_configure() {
mate_src_configure \
--disable-update-mimedb \
$(use_enable introspection) \
$(use_enable packagekit) \
$(use_enable xmp)
}

src_test() {
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS

Xemake check || die "Test phase failed"
}

pkg_postinst() {
mate_pkg_postinst

elog "Caja can use gstreamer to preview audio files. Just make sure"
elog "to have the necessary plugins available to play the media type you"
elog "want to preview."
}

0 comments on commit 707ee9d

Please sign in to comment.