Skip to content

Commit

Permalink
app-admin/sysstat: Version 12.3.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Apr 10, 2020
1 parent bda3ec7 commit 708a106
Show file tree
Hide file tree
Showing 2 changed files with 82 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/sysstat/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST sysstat-12.2.1.tar.gz 1227707 BLAKE2B 566382d83a0230517d22e2630a9cb1aa631d761c914188a4e7fb15eddaedbd25b8a3dffa9893b1b2bbcc31d87a37cbe11b2b50ab0ec94a28f84018685d1b35c8 SHA512 a19d0978eb11071c228462cda496a59721541e57a1d15cb2d0964f287ac2d50b5587fa5bc2b8fe6be2a1f00cbf2e7c3bc59db6494e3e8c1906aa81437b30d073
DIST sysstat-12.3.1.tar.gz 1245248 BLAKE2B 69848c452642be992c7b4af33268c0d6b30f16e5ea44ec13b00ab57e6ec3b498d92b707a53757de9066138a9ee92b995765f44f75f692e1b3c68d829519d53ca SHA512 f67a2dac22748217687bd7f58521c0719754f13298fb5faed8a6d58c2bb1f8620428191d0415e816eea07bb3ca81453e057d03c7db0096430ad7d6ba6b7b611e
DIST sysstat-12.3.2.tar.gz 1335057 BLAKE2B e075d0def13cd786dd0c3c49d0770cfe3e946a6b6f500e4364bc30d79fdec08ee8b4c4a2ef3b0188da3435f5921e0b27c8dbd8845a6c6116cba88f8684992674 SHA512 e78feb082a6ccd634f1f1565769b56a6b7aee95853334e73395489445f6f0d96d2b5bdfeacec16f4530be8383ebc3b6b126e7df93abc3e67c409b3791d02e275
81 changes: 81 additions & 0 deletions app-admin/sysstat/sysstat-12.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit eutils flag-o-matic systemd toolchain-funcs

DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="debug nls lm-sensors selinux static"

CDEPEND="
nls? ( virtual/libintl )
lm-sensors? ( sys-apps/lm-sensors:= )
"
DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )
"
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-sysstat )
"
PATCHES=(
"${FILESDIR}"/${PN}-11.0.4-cron.patch
"${FILESDIR}"/${PN}-11.7.3-flags.patch
)

src_prepare() {
if use nls; then
strip-linguas -i nls/
local lingua pofile
for pofile in nls/*.po; do
lingua=${pofile/nls\/}
lingua=${lingua/.po}
if ! has ${lingua} ${LINGUAS}; then
rm "nls/${lingua}.po" || die
fi
done
fi

default
}

src_configure() {
tc-export AR
use static && append-ldflags -static

sa_lib_dir=/usr/lib/sa \
conf_dir=/etc \
econf \
$(use_enable lm-sensors sensors) \
$(use_enable nls) \
$(usex debug --enable-debuginfo '') \
--enable-copy-only \
--enable-documentation \
--enable-install-cron \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)
}

src_install() {
keepdir /var/log/sa

emake \
CHOWN=true \
DESTDIR="${D}" \
DOC_DIR=/usr/share/doc/${PF} \
MANGRPARG='' \
install

dodoc -r contrib/

newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service

rm "${D}"/usr/share/doc/${PF}/COPYING || die
}

0 comments on commit 708a106

Please sign in to comment.