Skip to content

Commit

Permalink
media-video/recordmydesktop: switched dependency to virtual/jack and …
Browse files Browse the repository at this point in the history
…updated to eapi 6

Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
fordfrog committed Mar 20, 2018
1 parent 87e32e5 commit 70bcae9
Showing 1 changed file with 59 additions and 0 deletions.
59 changes: 59 additions & 0 deletions media-video/recordmydesktop/recordmydesktop-0.3.8.1-r5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils autotools

DESCRIPTION="A desktop session recorder producing Ogg video/audio files"
HOMEPAGE="http://recordmydesktop.sourceforge.net/"
SRC_URI="mirror://sourceforge/recordmydesktop/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="alsa jack"

RDEPEND="sys-libs/zlib
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXdamage
media-libs/libvorbis
media-libs/libogg
media-libs/libtheora[encode]
x11-libs/libICE
x11-libs/libSM
alsa? ( media-libs/alsa-lib )
jack? ( virtual/jack )"
DEPEND="${RDEPEND}
x11-proto/xextproto"

src_prepare() {
if has_version ">=x11-proto/xextproto-7.1.1"; then
sed -i \
-e 's:shmstr.h:shmproto.h:g' \
src/rmd_{getzpixmap.c,update_image.c} || die
fi

# fix weird Framerates with new libtheora
epatch "${FILESDIR}/${PV}-fix_new_theora.patch"

# fix check for jack support
epatch "${FILESDIR}/${PV}-fix-libjack-check.patch"

eapply_user

eautoreconf
}

src_configure() {
econf \
--enable-dependency-tracking \
$(use_enable !alsa oss) \
$(use_enable jack)
}

src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README || die
}

0 comments on commit 70bcae9

Please sign in to comment.