Skip to content

Commit

Permalink
dev-util/cutter: bump to version 1.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Closes: gentoo#9141
  • Loading branch information
otakuto authored and a17r committed Jul 8, 2018
1 parent fa29fbe commit 70e79d7
Show file tree
Hide file tree
Showing 4 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/cutter/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cutter-1.0.tar.gz 614826 BLAKE2B 8f75343e57bf986d80dde3dc3ceb59675d28854744d8cc5fac783514e9c200595990d4860ee45db6544537d4f367df5b62a034e298bf273e44302edfa1647c84 SHA512 af6be59be7871d21d4f665e8ecb7f8224d99ccf7d62793e989ccd780ee521641c6ec0d941b46bb82770f5d44e5c0ef2efc29f9be303385e8e757e62a54bf53b1
DIST cutter-1.4.tar.gz 1067162 BLAKE2B 2f7eceffcfb3c542695e03ec72de1c99451f8278e91f50abc2e87542efbd2cc73d5a52b0e5303b9cea751edf91bc71b63295edd5b32d1b2b9ed3a1443cfc92e7 SHA512 54caec67e57f2ff3908942c1ebd1e909c65204c6f31d0ec95e31f46e03364f309898006b93555ba81287c0d74faf407272226e5ec65b3148ecde8feec11ca3be
46 changes: 46 additions & 0 deletions dev-util/cutter/cutter-1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit qmake-utils

DESCRIPTION="A Qt and C++ GUI for radare2 reverse engineering framework"
HOMEPAGE="https://www.radare.org"
SRC_URI="https://github.com/radareorg/cutter/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="jupyter webengine"
REQUIRED_USE="webengine? ( jupyter )"

DEPEND="
>=dev-qt/qtcore-5.9.1:5
>=dev-qt/qtgui-5.9.1:5
>=dev-qt/qtsvg-5.9.1:5
>=dev-qt/qtwidgets-5.9.1:5
>=dev-util/radare2-2.6.0
jupyter? ( dev-python/jupyter )
webengine? ( >=dev-qt/qtwebengine-5.9.1:5[widgets] )
"

RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}/${P}-python3-config.patch"
)

src_configure() {
local myqmakeargs=(
CUTTER_ENABLE_JUPYTER=$(usex jupyter true false)
CUTTER_ENABLE_QTWEBENGINE=$(usex webengine true false)
PREFIX=\'${EPREFIX}/usr\'
)

eqmake5 "${myqmakeargs[@]}" src
}

src_install() {
emake INSTALL_ROOT="${D}" install
}
20 changes: 20 additions & 0 deletions dev-util/cutter/files/cutter-1.4-python3-config.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
--- a/src/Cutter.pro 2018-04-24 17:43:11.000000000 +0900
+++ b/src/Cutter.pro 2018-07-08 21:21:34.280748499 +0900
@@ -74,11 +74,13 @@
LIBS += -F$$PYTHON_FRAMEWORK_DIR -framework Python
DEFINES += MACOS_PYTHON_FRAMEWORK_BUNDLED
} else {
- CONFIG += link_pkgconfig
- !packagesExist(python3) {
- error("ERROR: Python 3 could not be found. Make sure it is available to pkg-config.")
+ system(type python3-config) {
+ LIBS += $$system(python3-config --libs)
+ TMP = $$system(python3-config --includes)
+ INCLUDEPATH += $$replace(TMP, "-I", "")
+ } else {
+ error("ERROR: Python 3 could not be found. Make sure it is available to python3-config.")
}
- PKGCONFIG += python3
}
}

4 changes: 4 additions & 0 deletions dev-util/cutter/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -12,4 +12,8 @@
<upstream>
<remote-id type="github">radareorg/cutter</remote-id>
</upstream>
<use>
<flag name="jupyter">Add support for jupyter notebook</flag>
<flag name="webengine">Use <pkg>dev-qt/qtwebengine</pkg> for in-app jupyter browser</flag>
</use>
</pkgmetadata>

0 comments on commit 70e79d7

Please sign in to comment.