Skip to content

Commit

Permalink
mate-base/mate-settings-daemon: Bump to 1.24.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Adam Feldman <[email protected]>
  • Loading branch information
NP-Hardass committed Sep 25, 2020
1 parent 2dc145c commit 7121134
Showing 1 changed file with 73 additions and 0 deletions.
73 changes: 73 additions & 0 deletions mate-base/mate-settings-daemon/mate-settings-daemon-1.24.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MATE_LA_PUNT="yes"

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

DESCRIPTION="MATE Settings Daemon"
LICENSE="GPL-2+ GPL-3+ HPND LGPL-2+ LGPL-2.1+"
SLOT="0"

IUSE="X debug libnotify policykit pulseaudio rfkill smartcard +sound"

REQUIRED_USE="pulseaudio? ( sound )"

COMMON_DEPEND=">=dev-libs/dbus-glib-0.74
>=dev-libs/glib-2.50:2
>=gnome-base/dconf-0.13.4
>=mate-base/libmatekbd-1.17.0
>=mate-base/mate-desktop-1.23.2
media-libs/fontconfig:1.0
x11-libs/cairo
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.22:3
x11-libs/libX11
x11-libs/libXi
x11-libs/libXext
>=x11-libs/libxklavier-5.2
libnotify? ( >=x11-libs/libnotify-0.7:0 )
policykit? (
>=dev-libs/dbus-glib-0.71
>=sys-apps/dbus-1.10.0
>=sys-auth/polkit-0.97
)
pulseaudio? (
>=media-libs/libmatemixer-1.10[pulseaudio]
>=media-sound/pulseaudio-0.9.15
)
smartcard? ( >=dev-libs/nss-3.11.2 )
sound? (
>=media-libs/libmatemixer-1.10
media-libs/libcanberra[gtk3]
)
"

RDEPEND="${COMMON_DEPEND}
virtual/libintl
"

DEPEND="${COMMON_DEPEND}
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
x11-base/xorg-proto
"

src_configure() {
mate_src_configure \
$(use_with X x) \
$(use_with libnotify) \
$(use_with sound libcanberra) \
$(use_with sound libmatemixer) \
$(use_enable debug) \
$(use_enable policykit polkit) \
$(use_enable pulseaudio pulse) \
$(use_enable rfkill) \
$(use_enable smartcard smartcard-support)
}

0 comments on commit 7121134

Please sign in to comment.